Yii Framework Forum: Problem with SoapClient - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • This topic is locked

Problem with SoapClient Rate Topic: -----

#1 User is offline   irajab 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 6
  • Joined: 25-February 10

Posted 08 January 2011 - 04:24 AM

Hi, I'm new in WebService and I have a project that's need me to use it.

My problem is when calling creating a new SoapClient I got this error:

Code:
$client = new SoapClient('https://extws.xxxx.com/extws/services/xxxxxxx');


Error:
SoapClient::SoapClient() [<a href='soapclient.soapclient'>soapclient.soapclient</a>]: Unable to find the wrapper &quot;https&quot; - did you forget to enable it when you configured PHP?


Could anyone please tell me what I'm doing wrong??

Thanks in advance.
0

#2 User is offline   irajab 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 6
  • Joined: 25-February 10

Posted 08 January 2011 - 04:39 AM

Sorry, it was a stupid mistake from me and doesn't have to do with SoapClient I forgot to enable the openSSL extension in PHP.INI
0

#3 User is offline   weirdcanada 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 10
  • Joined: 04-June 11

Posted 15 August 2011 - 05:06 PM

Not a stupid question! This was useful for me :)

(though, yes, should have known to check the PHP.INI settings)

Thank you.
0

#4 User is offline   Giancarlo 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 249
  • Joined: 20-December 11
  • Location:Turin, Italy

Posted 07 February 2012 - 04:08 AM

add in php.ini this line:
extension=php_openssl.dll
Posted Image Non preoccuparti, รจ dentro il monitor!

Sapevi che cercando su google yii2 + "la funzione su cui stai impazzendo", trovi quasi sempre dei buoni indizi in italiano, per risolvere i tuoi problemi, senza perdere tempo a postare?
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • This topic is locked

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users