Yii 1.1.15 is released (security fix)

Jun 29, 2014

We are releasing Yii 1.1.15 to fix a security issue found in 1.1.14. We urge all 1.1.14 users to upgrade their Yii to this latest release. Note that the issue only affects 1.1.14. All previous releases are not affected. Upgrading to this release from 1.1.14 is very safe and will not break your existing code.

The vulnerability is in the CDetailView widget. When a Yii application uses this widget and configures the "value" property of a CDetailView attribute using end user inputs, it may allow attackers to potentially execute arbitrary PHP scripts on the server. We are not showing how to exploit it here to allow users to upgrade before details about the exploit become publicly known. To our knowledge the details of this issue are only known to core team members.

We have reserved for this issue a CVE number (CVE-2014-4672) which you can use to refer to it.