Yii 2.0: yii2-errorstream

Yii2 integration with errorstream.com
1 follower

This package is for yii2 integration with ErrorStream.com.

We prefer you install this with composer. You can find complete up to date information Here.

Installation ΒΆ

First, run the following command on the terminal to download and install the package

composer require errorstream/errorstream-yii2

Next, register the client class in your web.php configuration file. You can find your API token and Project token on the project settings page inside of errorstream.com.

'components' => [
        ...
        'errorstream' => [
            'class'             => 'ErrorStream\ErrorStreamClient\ErrorStreamClient',
            'api_token'         => 'YOUR_API_TOKEN', //Put your api token here
            'project_token'     => 'YOUR_PROJECT_TOKEN', //Put your project token here
            'active'            => true, //You might want to only activate this in production mode
        ]
        ...
    ]

Next, you want to edit the errorHandler setting in web.php configuration file. You'll want to place the ErrorStreamErrorHandler as a 'class' for your error handler, like this.

'components' => [
    ...
    'errorHandler' => [
        'errorAction' => 'site/error',
        'class' => 'ErrorStream\ErrorStream\ErrorStreamErrorHandler',
    ],
    ...
]

Finally, you want to edit the errorHandler setting in web.php configuration file. You'll want to place the ErrorStreamErrorHandler as a 'class' for your error handler, like this.

'components' => [
        ...
        'log' => [
            ..
            'targets' => [
                ...
                [
                    'class' => 'ErrorStream\ErrorStream\ErrorStreamLogger',
                    'levels' => ['error', 'warning'], //Only send errors and warnings.
                    'logVars' => [], //Necessary so you don't submit every request to our server.
                ],
                ...
            ],
        ]
    ]

Be the first person to leave a comment

Please to leave your comment.

Create extension