Yii Framework Forum: Fatal error: Declaration of Codeception\PHPUnit\Listener::addError - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Fatal error: Declaration of Codeception\PHPUnit\Listener::addError

#1 User is offline   Nikhil Vijayan 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 1
  • Joined: 14-February 16

Posted 25 July 2018 - 02:41 PM

I am getting this error when trying to run codcept right after a fresh yii2 install(basic template). My php version is 7.1.16

Quote

$ codecept run

Codeception PHP Testing Framework v2.4.4
Powered by PHPUnit 7.1.5 by Sebastian Bergmann and contributors.

Fatal error: Declaration of Codeception\PHPUnit\Listener::addError(PHPUnit\Framework\Test $test, Throwable $e, float $time): void must be compatible with PHPUnit\Framework\TestListener::addError(PHPUnit\Framework\Test $test, Exception $e, $time) in /Users/nikhil/Projects/yaty/vendor/codeception/phpunit-wrapper/src/Listener.php on line 13

0

#2 User is offline   alrazi 

  • Elite Member
  • Yii
  • Group: Moderators
  • Posts: 1,556
  • Joined: 08-August 12
  • Location:Durban, South Africa

Posted 27 July 2018 - 01:42 AM

Codeceptions is build on top of phpunit looks like you have the latest version of phpunit and codeceptions does not support it.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users