Yii Framework Forum: Problem with npm-asset dependencies - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Problem with npm-asset dependencies Two versions of the same library are required Rate Topic: -----

#1 User is offline   Cronopios 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 2
  • Joined: 31-May 16

Posted 02 July 2018 - 04:01 PM

I am trying to install puppeteer:

composer require npm-asset/puppeteer


However
* npm-asset/puppeteer requires npm-asset/extract-zip and npm-asset/debug >=3.1.0
* npm-asset/extract-zip requires npm-asset/debug 2.6.9

The conclusion is that puppeteer is not installed, because composer can only install one of: npm-asset/debug[2.6.9, 3.1.0].

Is there any way to resolve this?


FWIW, I can run
npm install puppeteer
successfully. I guess NPM can install multiple versions of the same library, while Composer can only have one.

I have Yii 2.0.15.1, Composer 1.6.5 and npm 5.6.0.
0

#2 User is offline   Cronopios 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 2
  • Joined: 31-May 16

Posted 06 July 2018 - 06:28 AM

I worked around this re-enabling temporally the composer asset plugin:

"fxp-asset": {
    "enabled": true,
    "resolutions": {
        "npm-asset/debug": "^3.1"
    }
}

but I wonder if there is not any way to achieve this using asset-packagist...
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users