Yii Framework Forum: Yii 2.0.15 update fails - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Yii 2.0.15 update fails Rate Topic: -----

#1 User is offline   ED42 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 05-June 17

Posted 20 May 2018 - 07:45 AM

Just tried to update my 2.0.14 install (on current Debian), according to:
https://www.yiiframe...-security-fixes
..with the command:
composer require "yiisoft/yii2":"~2.0.15.0"

It failed with this error:
    [RuntimeException]
    Could not delete /var/www/../vendor/bin/yii:  

Next I tried
sudo composer..
- which gets rejected - root is not allowed.

Then, search via google found this article:
https://www.yiiframe...vendor-packages

So I archived and deleted vendor/ and composer.lock and started:
php composer.phar install 


Then I got the error
    .../yiisoft/yii2-composer does not exist and could not be created.

So it seems this parameter has to be set - to which value?:
--prefer-dist

Or, if the above wiki article is not the solution, what could help (after restoring the archive)?
1

#2 User is offline   _marcelo 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 68
  • Joined: 22-October 15

Posted 21 May 2018 - 08:07 AM

Don't run composer with sudo!!!

It's like a permission issue. Check that!
0

#3 User is offline   ED42 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 05-June 17

Posted 22 May 2018 - 07:49 AM

View Post_marcelo, on 21 May 2018 - 08:07 AM, said:

It's like a permission issue. Check that!

Permissions have not changed since the last update, from 2.0.13 to 14.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users