Yii Framework Forum: gravatar - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

gravatar Rate Topic: -----

#1 User is offline   mithereal 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 67
  • Joined: 14-April 10
  • Location:The Radioactive Desert, AZ

Posted 16 April 2010 - 02:12 PM

im using the gravatar extension but no default image is showing, i right click the image thats supposed to be there and the image path is correct as seen by going directly to the url ie. http://localhost/image.jpg but in the applixcation is shows a blank image any isdeas
0

#2 User is offline   Vince. 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 432
  • Joined: 29-December 08
  • Location:Los Angeles,CA

Posted 16 April 2010 - 02:31 PM

Gravatar supports some default missing images. If you set the gravatar component propert 'default' to null or an empty string the default blue G avatar will be shown for the users who don't have one. You can also use "identicon" "monsterid" and "wavatar" as default avatars.
Vince Gabriel, Lead Developer.
Posted ImagePosted ImagePosted Image
0

#3 User is offline   mithereal 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 67
  • Joined: 14-April 10
  • Location:The Radioactive Desert, AZ

Posted 16 April 2010 - 02:43 PM

View PostVince., on 16 April 2010 - 02:31 PM, said:

Gravatar supports some default missing images. If you set the gravatar component propert 'default' to null or an empty string the default blue G avatar will be shown for the users who don't have one. You can also use "identicon" "monsterid" and "wavatar" as default avatars.

what if i want to use a local avatar in case the user does not have one
0

#4 User is offline   Vince. 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 432
  • Joined: 29-December 08
  • Location:Los Angeles,CA

Posted 16 April 2010 - 02:52 PM

Then just enter the full path url for that avatar image.
Vince Gabriel, Lead Developer.
Posted ImagePosted ImagePosted Image
0

#5 User is offline   mithereal 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 67
  • Joined: 14-April 10
  • Location:The Radioactive Desert, AZ

Posted 16 April 2010 - 02:59 PM

View PostVince., on 16 April 2010 - 02:52 PM, said:

Then just enter the full path url for that avatar image.

and i have done that, still shoes no image. but when i right click, view image it shows.
heres my view
$this->widget('application.extensions.VGGravatarWidget',
array(
'email' => $model->email, // email to display the gravatar belonging to it
'hashed' => false, // if the email provided above is already md5 hashed then set this property to true, defaults to false
'default' => 'http://127.0.0.1/site/images/avatar.jpg', // if an email is not associated with a gravatar this image will be displayed default http://www.mysite.co...vatar_image.jpg'
// by default this is omitted so the Blue Gravatar icon will be displayed you can also set this to
// "identicon" "monsterid" and "wavatar" which are default gravatar icons
'size' => 120, // the gravatar icon size in px defaults to 40
'rating' => 'PG', // the Gravatar ratings, Can be G, PG, R, X, Defaults to G
'htmlOptions' => array( 'alt' => 'Gravatar Icon' ), // Html options that will be appended to the image tag
));
0

#6 User is offline   Vince. 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 432
  • Joined: 29-December 08
  • Location:Los Angeles,CA

Posted 17 April 2010 - 03:24 AM

I just went a head and tested this to see if that actually worked with an images located on localhost and it did for me. So make sure you use the correct image URL. When you copy and paste that image into the browser does that work?
Vince Gabriel, Lead Developer.
Posted ImagePosted ImagePosted Image
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users