Yii Framework Forum: YiiBase.php - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

YiiBase.php Rate Topic: -----

#1 User is offline   maciur 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 11
  • Joined: 06-April 10
  • Location:Poland

Posted 06 April 2010 - 08:34 AM

Witam!

Z tego względu, że jest to mój pierwszy post to wszystkich serdecznie witam :). Od jakiegoś czasu chciałem wypróbować CMS oparty o Yii, phundament 2 jest nawet przedstawiony na tym forum :) link . Ale problem pojawia się już na samym początku bo nawet nie mogę go zainstalować. Ale to chyba nie jest problem CMS'a lecz samego Yii. Otóż, gdy wpisuję ./yiic install, pojawia mi się w shellu komunikat:

X-Powered-By: PHP/4.4.9
Content-type: text/html

<br />
<b>Parse error</b>:  syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in <b>/djpromo/yii/lib/yii/YiiBase.php</b> on line <b>59</b><br />


Nie wiem dlaczego tak jest. Ale podejrzewam, że to problem serwera bo nie pokoi mnie ten nagłowek "X-Powered-By: PHP/4.4.9" chociaż PHP jest ustawione na 5. Mój dostawca hostingu to ovh.pl. Niczego podobnego nie znalazłem na forum więc zwracam się o pomoc do was :). Aaa i dopiero zaczynam zabawę z Yii.

Pozdrawiam i dziękuję za pomoc :)
0

#2 User is offline   aztech 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 206
  • Joined: 12-December 08
  • Location:Poland

Posted 07 April 2010 - 09:18 AM

Witam,

sprawdź może czy serwer spełnia wymagania. Stawiam dolary przeciwko orzechom, że nie są one spełniane a Twoje przypuszczenia co do wersji są najprawdopodobniej słuszne.

pozdrawiam, Tomek
I'm not complete idiot... some parts are missing!
0

#3 User is offline   maciur 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 11
  • Joined: 06-April 10
  • Location:Poland

Posted 08 April 2010 - 12:53 AM

Witaj!

Tak masz racje, mam dostępny PHP 5 na serwerze ale nie poprzez linie poleceń, to jest przyczyną. Pomogli mi ludzie z tego forum :) link. Ale chyba skończy się na zmianie dostawcy ale zobaczymy :) .

//Edit

Dostałem dzisiaj odpowiedz od supportu, wystarczyło wpisać php.ORIG.5 ./yiic install i wszystko działa poprawnie :).

Pozdrawiam!

Maciej
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users