Yii Framework Forum: Stay away from php 5.3.1 - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Stay away from php 5.3.1 Rate Topic: -----

#1 User is offline   notzippy 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 201
  • Joined: 06-October 08

Posted 19 March 2010 - 11:54 AM

Hi

This PHP version (5.3.1) is the one that comes with the latest XAMPP 1.7.3
It appears that this version has a reference bug which causes the following badness
$temp=new CMap;
$temp['a']=array("foo"=>"bar");
$temp['a']["rr"]=5;
print_r($temp);

What this version of php returns
CMap Object
(
    [_d:CMap:private] => Array
        (
            [a] => Array
                (
                    [foo] => bar
                )

        )

    [_r:CMap:private] => 
    [_e:CComponent:private] => 
    [_m:CComponent:private] => 
)



nz
0

#2 User is offline   vamp 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 181
  • Joined: 30-January 09

Posted 01 April 2010 - 09:57 AM

View Postnotzippy, on 19 March 2010 - 11:54 AM, said:

Hi

This PHP version (5.3.1) is the one that comes with the latest XAMPP 1.7.3
It appears that this version has a reference bug which causes the following badness
$temp=new CMap;
$temp['a']=array("foo"=>"bar");
$temp['a']["rr"]=5;
print_r($temp);

What this version of php returns
CMap Object
(
    [_d:CMap:private] => Array
        (
            [a] => Array
                (
                    [foo] => bar
                )

        )

    [_r:CMap:private] => 
    [_e:CComponent:private] => 
    [_m:CComponent:private] => 
)



nz


it generates warning, you try incorrectly set value to overloaded property
-Posted Image-
Thanks, you make me stronger!
0

#3 User is offline   notzippy 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 201
  • Joined: 06-October 08

Posted 01 April 2010 - 10:02 AM

True that, Actually that ended up being the least of my issues with 5.3, most of the automatic importing failed in various spots. In the end it was just easier to use an older version of php...

nz
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users