Yii Framework Forum: Revision 1874 - New 'form' shell command error - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Revision 1874 - New 'form' shell command error Rate Topic: -----

#1 User is offline   outrage 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 313
  • Joined: 10-November 09
  • Location:Blackpool, United Kingdom

Posted 10 March 2010 - 01:59 PM

Hi Guys,

Just wanted to run this by you before I report it as a bug because I'm probably doing something wrong :)

I wanted to try out the new shell command - 'form' but when I try it, I get the following error:

>> form Clients protected.views.clientform.client

Parse error: syntax error, unexpected T_STRING in C:\xampp\htdocs\formyii\framework\cli\commands ShellCommand.php(147) : eval()'d code on line 1

Call Stack:
    0.0006     321616   1. {main}() C:\xampp\htdocs\formyii\protected\yiic:0
    0.0017     324288   2. require_once('C:\xampp\htdocs\formyii\protected\yiic.php') C:\xampp\htdocs\formyii\protected\yiic:4
    0.0044     333344   3. require_once('C:\xampp\htdocs\formyii\framework\yiic.php') C:\xampp\htdocs\formyii\protected\yiic.php:7
    0.0693    1086776   4. CApplication->run() C:\xampp\htdocs\formyii\framework\yiic.php:30
    0.0694    1086776   5. CConsoleApplication->processRequest() C:\xampp\htdocs\formyii\framework\base\CApplication.php:135
    0.0694    1086776   6. CConsoleCommandRunner->run() C:\xampp\htdocs\formyii\framework\console\CConsoleApplication.php:88
    0.0789    1207008   7. ShellCommand->run() C:\xampp\htdocs\formyii\framework\console\CConsoleCommandRunner.php:62
    1.9149    4907840   8. ShellCommand->runShell() C:\xampp\htdocs\formyii\framework\cli\commands\ShellCommand.php:99


Has anyone tried this yet and got different results?
0

#2 User is offline   qiang 

  • Yii Project Lead
  • Yii
  • Group: Yii Dev Team
  • Posts: 5,907
  • Joined: 04-October 08
  • Location:DC, USA

Posted 10 March 2010 - 05:41 PM

Are you using trunk? I couldn't reproduce the issue.
0

#3 User is offline   outrage 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 313
  • Joined: 10-November 09
  • Location:Blackpool, United Kingdom

Posted 11 March 2010 - 04:42 PM

Hi Qiang, thanks for looking into it.

Yes I updated my SVN copy from the trunk yesterday.

PHP 5.3 & MySQL on Apache, Windows.

Other shell commands work just fine but I get error with 'form' using it against an existing model.
0

#4 User is offline   outrage 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 313
  • Joined: 10-November 09
  • Location:Blackpool, United Kingdom

Posted 11 March 2010 - 06:00 PM

Hi Qiang,

This issue is fixed in revision 1887 :)

Cheers.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users