Yii Framework Forum: error composer - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

error composer Rate Topic: -----

#1 User is offline   Jose_Mesa 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 45
  • Joined: 10-August 16

Posted 21 October 2017 - 01:06 PM

buenos tardes,

quiero instalar el adminlte en yii2 pero me sale el siquiente error:

problem 1 -sebastian/recursion-context 3.0.0 requires php ^7.0 -> your php version <5.6.3 does not satisfy that requirement

installation failed reverting ./composer.json to its original content

este es mi composer.json

"name": "yiisoft/yii2-app-advanced",
"description": "Yii 2 Advanced Project Template",
"keywords": ["yii2", "framework", "advanced", "project template"],
"homepage": "http://www.yiiframework.com/",
"type": "project",
"license": "BSD-3-Clause",
"support": {
"issues": "https://github.com/yiisoft/yii2/issues?state=open",
"forum": "http://www.yiiframework.com/forum/",
"wiki": "http://www.yiiframework.com/wiki/",
"irc": "irc://irc.freenode.net/yii",
"source": "https://github.com/yiisoft/yii2"
},
"minimum-stability": "stable",
"require": {
"php": ">=5.4.0",
"yiisoft/yii2": "~2.0.6",
"yiisoft/yii2-bootstrap": "~2.0.0",
"yiisoft/yii2-swiftmailer": "~2.0.0",
"2amigos/yii2-date-picker-widget" : "~1.0",
"phpoffice/phpexcel": "dev-develop"
},
"require-dev": {
"yiisoft/yii2-debug": "~2.0.0",
"yiisoft/yii2-gii": "~2.0.0",
"yiisoft/yii2-faker": "~2.0.0",

"codeception/base": "^2.2.3",
"codeception/verify": "~0.3.1"
},
"config": {
"process-timeout": 1800,
"fxp-asset":{
"installer-paths": {
"npm-asset-library": "vendor/npm",
"bower-asset-library": "vendor/bower"
}
}
}
}

agradeceria su gran ayuda
0

#2 User is offline   Menapro 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 53
  • Joined: 27-October 16
  • Location:Burgos, Spain

Posted 22 October 2017 - 04:15 AM

¿Que paquete de AdminLTE estás instalando?

Es un error con tu versión de PHP, necesitas PHP7. Si tienes varias versiones de PHP instaladas en el mismo equipo, y estás seguro de que tienes php7 puedes hacer un
composer update --ignore-platform-reqs
. Esto ignorará los requerimientos de versiones y otros de los paquetes.
0

#3 User is offline   Jose_Mesa 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 45
  • Joined: 10-August 16

Posted 23 October 2017 - 11:39 AM

Hola Menapro gracias por contestarme, pues el paquete que quiero instalar es el siguiente:

php composer.phar require dmstr/yii2-adminlte-asset "2.*"

pero al estar cargando me sale el error que ya tu sabes, pues ya instale el paquete que me dijiste pero de la siguiente manera php composer.phar update --ignore-platform-reqs y segui a instalar el ultimo y igual me sale el error de siempre.

agradeceria tu ayuda si tienes alguna otra solucion.

saludos.
0

#4 User is offline   lagogz 

  • Master Member
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 739
  • Joined: 30-November 12
  • Location:Galiza

Posted 14 November 2017 - 02:32 AM

Buenas.

"problem 1 -sebastian/recursion-context 3.0.0 requires php ^7.0 -> your php version <5.6.3 does not satisfy that requirement"

Necesitas php7 y tienes instalado php 5.6.3.

Un saludo.
-----------------------------------------------------------------------------------------------
------------------------------- VISITEN FOCUCHASART --------------------------------
-----------------------------------------------------------------------------------------------
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users