Yii Framework Forum: Install yii 2.0.5 - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Install yii 2.0.5 Install previous versions of Yii2 Rate Topic: -----

#1 User is offline   donvikky 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 11
  • Joined: 21-October 14

Posted 25 July 2017 - 03:49 AM

Hello for certain reasons, i need to install a previous version of yii2, specifically 2.0.5. How do i go about this?
0

#2 User is offline   samdark 

  • Having fun
  • Yii
  • Group: Yii Dev Team
  • Posts: 5,184
  • Joined: 17-January 09
  • Location:Russia

Posted 25 July 2017 - 10:29 AM

From scratch or for existing project?

For existing project — adjust dependency in composer.json, run "composer update".

For new project:

composer global require "fxp/composer-asset-plugin:^1.3.1"
composer create-project --prefer-dist yiisoft/yii2-app-basic basic 2.0.5
Yii 2.0 Development Cookbook

Enjoying Yii? Star us at github

Support me so I can work more on Yii: https://www.patreon.com/samdark
0

#3 User is offline   donvikky 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 11
  • Joined: 21-October 14

Posted 26 July 2017 - 03:15 AM

View Postsamdark, on 25 July 2017 - 10:29 AM, said:

From scratch or for existing project?

For existing project — adjust dependency in composer.json, run "composer update".

For new project:

composer global require "fxp/composer-asset-plugin:^1.3.1"
composer create-project --prefer-dist yiisoft/yii2-app-basic basic 2.0.5


Hello Sandmark

I already tried that and got the following error:

[InvalidArgumentException]
Could not find package yiisoft/yii2-app-basic with version 2.0.5.

create-project [-s|--stability STABILITY] [--prefer-source] [--prefer-dist] [--repository REPOSITORY] [--repository-url REPOSITORY-URL] [--dev] [--no-dev] [--no-custom-installers] [--no-scripts] [--no-progress] [--no-secure-http] [--keep-vcs] [--no-install] [--ignore-platform-reqs] [--] [<package>] [<directory>] [<version>]

Is there anything additional thing I should be doing?
0

#4 User is offline   samdark 

  • Having fun
  • Yii
  • Group: Yii Dev Team
  • Posts: 5,184
  • Joined: 17-January 09
  • Location:Russia

Posted 26 July 2017 - 05:07 AM

Right. There's no 2.0.5 for the application template. Install 2.0.4 then update yiisoft/yii2 dependency in composer.json to "2.0.5" and run "composer update".
Yii 2.0 Development Cookbook

Enjoying Yii? Star us at github

Support me so I can work more on Yii: https://www.patreon.com/samdark
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users