Yii Framework Forum: Yii2 debugger issues after version update - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Yii2 debugger issues after version update Debugger doesn't show db queries and/or performance profiling

#1 User is offline   Naboovalley 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 40
  • Joined: 18-November 14

Posted 17 July 2017 - 08:50 AM

I have this wierd issue after a composer update to the latest version of yii2 in my project.

For some reason the debugger doesn't display any database queries and/or performance profiling. Everything else in the debugger works.

The actual tabs work but the tables are just... empty. Its the same with the "preview bottom bar". After the "Time.." and "Memory.." data points nothing else shows. The "DB (X)" column isn't there.

I should also meantion at the same time this code which always been giving me the database query count
$profiling = Yii::getLogger()->getDbProfiling();
just returns 0 now. I have no idea if that has anything to do with my debugger issue.

Any idea what could be wrong and where I should start troubleshooting?

Thank you
0

#2 User is offline   samdark 

  • Having fun
  • Yii
  • Group: Yii Dev Team
  • Posts: 5,184
  • Joined: 17-January 09
  • Location:Russia

Posted 18 July 2017 - 06:11 AM

What was the version that worked? What's current version? Any messages in runtime/log?
Yii 2.0 Development Cookbook

Enjoying Yii? Star us at github

Support me so I can work more on Yii: https://www.patreon.com/samdark
0

#3 User is offline   Naboovalley 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 40
  • Joined: 18-November 14

Posted 31 July 2017 - 02:29 AM

View Postsamdark, on 18 July 2017 - 06:11 AM, said:

What was the version that worked? What's current version? Any messages in runtime/log?

Hi samdark,

Sorry for the late late reply but here it goes. So current version is 2.0.12. I updated from 2.0.10.

I can't find anything related to this in the runtime/logs/app.log and if I add
$profiling = Yii::getLogger()->getDbProfiling();
to the bottom of my layout view all it returns is Array ( [0] => 0 [1] => 0 ) .

Any idea why the DB profiling isn't working?

Thank you so much
0

#4 User is offline   Naboovalley 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 40
  • Joined: 18-November 14

Posted 31 July 2017 - 02:37 AM

Could it be that the composer update -> push to server got it wrong and some files from the 2.0.10 version are still in there? Can I just download a manual copy of the 2.0.12 build and replace the /app/vendor/yiisoft folder with a fresh set of files to see if that makes any difference?

Thanks
0

#5 User is offline   Naboovalley 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 40
  • Joined: 18-November 14

Posted 31 July 2017 - 01:45 PM

SOLVED!

It must have been some faulty composer update, because I did what I did and re-ran everything (removed /vendor and ran composer update again and pushed all new files) and everything is back to normal.

Thanks
1

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users