Yii Framework Forum: Anforderungen für YII2 auf SUSE - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Anforderungen für YII2 auf SUSE Rate Topic: -----

#1 User is offline   beatcode 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 61
  • Joined: 13-May 11
  • Location:Zürich

Posted 16 May 2017 - 04:48 AM

Hallo Zusammen

Ich möchte für ein Experiment das Yii2 Framework einsetzen. Ich kann bei uns in der Firma eine SUSE VM ohne Root rechte bestellen. Nun möchte die Fachabteilung wissen, welche zusätzlichen Anforderungen zum Standard erforderlich sind. Versteht die Unix Fachabteilung, wenn ich ihnen das Bild der Requirements.php sende?


Reichen diese Installationen aus?

$ sudo apt-get update
$ sudo apt-get apache2
$ sudo apt-get install php5 libapache2-mod-php5 php5-mcrypt
$ sudo apt-get install mysql-server libapache2-mod-auth-mysql php5-mysql
Install Yii
$ curl -s http://getcomposer.org/installer | php
$ mv composer.phar /usr/local/bin/composer
$ composer global require "fxp/composer-asset-plugin:1.0.0"
$ cd /path/to/webroot/
$ composer create-project --prefer-dist yiisoft/yii2-app-basic basic

Oder kann mir jemand helfen die Minimum Anforderungen zu nennen?
- PHP 5.04 oder höher
- MYSQL (mit einem Applikationsuser)
- PDO Extension + PDO MySQL extension
- Apache (Zusatz Module bei Aapache?)
- FTP User


Optional
- GIT
- Composer
- CURL

Vielen Dank für Eure Hilfe.
Gruss Beat
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users