Yii Framework Forum: mhon bimbingan, Gagal Koneksi ke oracle - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

mhon bimbingan, Gagal Koneksi ke oracle Rate Topic: -----

#1 User is offline   omarxp 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 17
  • Joined: 12-February 10
  • Location:Yogyakarta

Posted 18 February 2010 - 10:46 PM

salam kenal buat para master,

saya ada masalah, saya ada 2 komputer, yang 1 untuk server database oracle os centos, yang 1 lg untuk develop website os windows, saya mw koneksi ke db oracle, tp gagal trs.
saya pake xampplite, oracle instant client jg sudah sya instal,

ini parameter di config/main.php :

'db'=>array(
'class' => 'CDbConnection',
'connectionString' => 'oci:dbname=//192.168.0.1:1521/test_db',
'username' => 'test_db',
'password' => 'test_db',
),

apa parameternya ada yang salah?
saya sudah berhasil masuk yiic shell, tp pas mw buat model, ada peringatan "TNS Listener does not currently know .... bla bla bla";


mohon pencerahan.... terimakasih
0

#2 User is offline   omarxp 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 17
  • Joined: 12-February 10
  • Location:Yogyakarta

Posted 22 February 2010 - 02:28 AM

sepiiiii, kok ga ada yang jawab :( :( :( :( :( :(
0

#3 User is offline   nasrul 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 98
  • Joined: 14-April 09
  • Location:Sorowako - Indonesia

Posted 23 February 2010 - 04:52 PM

saya belum pengalaman implementasi dg ORA. tapi kemungkinan masalah koneksi. kalau bukan konfigurasi web server (hhtpd.conf / php.ini) nya, bisa jadi masalah service ORADB di servernya. <_<
http://www.dba-oracl...lder_sqlnet.htm atau http://ora-12514.ora-code.com/ semoga bisa membantu. :)
0

#4 User is offline   omarxp 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 17
  • Joined: 12-February 10
  • Location:Yogyakarta

Posted 24 February 2010 - 02:27 AM

sekarang udah bisa buat model dan di crud, berhasil sih
tp begitu akses urlnya muncul error :

CDbConnection failed to open the DB connection: SQLSTATE[]: pdo_oci_handle_factory: <<Unknown>> (ext\pdo_oci\oci_driver.c:581)

aneh ga sih, udah bisa crud, tp diakses muncul error.
0

#5 User is offline   nasrul 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 98
  • Joined: 14-April 09
  • Location:Sorowako - Indonesia

Posted 24 February 2010 - 07:40 AM

hope this usefull http://id.php.net/ma...ction.php#70329 ?

coba non-aktifkan pdo_oci8nya, cukup pdo_oci saja.
php.ini
extension=php_pdo_oci.dll
;extension=php_pdo_oci8.dll

0

#6 User is offline   nasrul 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 98
  • Joined: 14-April 09
  • Location:Sorowako - Indonesia

Posted 28 February 2010 - 05:02 PM

omar, pake Yii versi berapa?
saya juga nemu kasus yii versi 1.1.0 (released 10 Januari 2010) tidak bisa create data dari model yang dibuat dari crud, namun di versi 1.0.x bisa.

kalau listing di v1.1.0 bisa, tapi untuk create / insert data ga bisa. ana belum coba modifikasi modelnya. any advice?

ana pake:
  • xampplite 1.7.2
  • windows7
  • PHP 5.3.0
  • Apache 2.0
  • sqlite3

0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users