Yii Framework Forum: Getting an error when i run acceptance test - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Getting an error when i run acceptance test

#1 User is offline   bmsrox 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 36
  • Joined: 03-August 11

Posted 15 December 2016 - 11:40 AM

I am trying to run acceptance tests, but i get this error. I am using yii 2.0.10

Scenario --
WebDriver::debugWebDriverLogs method has been called when webDriver is not set
WebDriver::_saveScreenshot method has been called when webDriver is not set
WebDriver::_savePageSource method has been called when webDriver is not set
Screenshot and page source were saved into '/var/www/html/ftdimprensa/tests/_output/' dir
ERROR



[Symfony\Component\Debug\Exception\FatalThrowableError]
Call to a member function resetPersistentVars() on null

acceptance.suite.yml

class_name: AcceptanceTester
modules:
enabled:
- WebDriver:
url: http://localhost:8080/
browser: chrome
- Yii2:
part: orm
entryScript: index-test.php
cleanup: false

I download selenium and chromedriver and run selenium server, but not working.
0

#2 User is offline   leviathan 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 2
  • Joined: 28-March 12

Posted 05 January 2017 - 05:02 AM

Did you find a solution?
I'm having the same Problem right now.
0

#3 User is offline   bmsrox 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 36
  • Joined: 03-August 11

Posted 11 January 2017 - 02:29 PM

Not yet :(
0

#4 User is offline   Nacesprin 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 87
  • Joined: 04-April 10
  • Location:San Fernando - Cadiz - Spain

Posted 29 November 2017 - 09:06 AM

View Postbmsrox, on 11 January 2017 - 02:29 PM, said:

Not yet :(


And now?
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users