Yii Framework Forum: Как установить Yii 2.0: yii2-ipinfo - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Как установить Yii 2.0: yii2-ipinfo Ошибки с композером Rate Topic: -----

#1 User is offline   Kocmuk 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 22-October 16
  • Location:Russia, Saratov

Posted 22 October 2016 - 10:54 AM

А все что мне нужно это установить и пользоваться расширением yii2-ipinfo

Но у меня не получается его устанавливать. Не понимаю проблем с композером

делаю
composer require kartik-v/yii2-ipinfo "@dev"

ответ с ошибкой

Quote

eAccelerator: Unable to change cache directory /tmp/eaccelerator permissions
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)

Your requirements could not be resolved to an installable set of packages.

Problem 1
- kartik-v/yii2-ipinfo dev-master requires kartik-v/yii2-icons ~1.4 -> satisfiable by kartik-v/yii2-icons[v1.4.0, v1.4.1].
- kartik-v/yii2-ipinfo 1.0.x-dev requires kartik-v/yii2-icons ~1.4 -> satisfiable by kartik-v/yii2-icons[v1.4.0, v1.4.1].
- kartik-v/yii2-icons v1.4.0 requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- kartik-v/yii2-icons v1.4.1 requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- yiisoft/yii2-jui 2.0.6 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.5 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.4 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.3 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.2 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.1 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.0 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- Installation request for kartik-v/yii2-ipinfo @dev -> satisfiable by kartik-v/yii2-ipinfo[dev-master, 1.0.x-dev].

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https:/ /getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https:/ /getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.



пробовал еще
composer require kartik-v/yii2-icons "@dev"

ответ с ошибкой

Quote

eAccelerator: Unable to change cache directory /tmp/eaccelerator permissions
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)

Your requirements could not be resolved to an installable set of packages.

Problem 1
- kartik-v/yii2-icons 1.0.0.x-dev requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- kartik-v/yii2-icons 1.1.0.x-dev requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- kartik-v/yii2-icons 1.2.0.x-dev requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- kartik-v/yii2-icons 1.3.0.x-dev requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- kartik-v/yii2-icons dev-master requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- kartik-v/yii2-icons v1.0.0 requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- kartik-v/yii2-icons v1.1.0 requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- kartik-v/yii2-icons v1.2.0 requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- kartik-v/yii2-icons v1.3.0 requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- kartik-v/yii2-icons v1.4.0 requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- kartik-v/yii2-icons v1.4.1 requires yiisoft/yii2-jui * -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].
- yiisoft/yii2-jui 2.0.6 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.5 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.4 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.3 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.2 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.1 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.0 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- Installation request for kartik-v/yii2-icons @dev -> satisfiable by kartik-v/yii2-icons[1.0.0.x-dev, 1.1.0.x-dev, 1.2.0.x-dev, 1.3.0.x-dev, dev-master, v1.0.0, v1.1.0, v1.2.0, v1.3.0, v1.4.0, v1.4.1].

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https:/ /getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https:/ /getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.



еще попробовал так
composer require --prefer-dist yiisoft/yii2-jui

ошибка такая

Quote

eAccelerator: Unable to change cache directory /tmp/eaccelerator permissions
Using version ^2.0 for yiisoft/yii2-jui
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)

Your requirements could not be resolved to an installable set of packages.

Problem 1
- yiisoft/yii2-jui 2.0.6 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.5 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.4 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.3 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.2 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.1 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- yiisoft/yii2-jui 2.0.0 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found.
- Installation request for yiisoft/yii2-jui ^2.0 -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6].

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https:/ /getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https:/ /getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.



и последнее что пробовал
composer require cebe/assetfree-yii2

ошибка

Quote

eAccelerator: Unable to change cache directory /tmp/eaccelerator permissions
Using version ^2.0 for cebe/assetfree-yii2
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)

Your requirements could not be resolved to an installable set of packages.

Problem 1
- cebe/assetfree-yii2 2.0.6 requires yiisoft/yii2 =2.0.6 -> satisfiable by yiisoft/yii2[2.0.6].
- cebe/assetfree-yii2 2.0.5 requires yiisoft/yii2 =2.0.5 -> satisfiable by yiisoft/yii2[2.0.5].
- cebe/assetfree-yii2 2.0.4 requires yiisoft/yii2 =2.0.4 -> satisfiable by yiisoft/yii2[2.0.4] but these conflict with your requirements or minimum-stability.
- cebe/assetfree-yii2 2.0.3 requires yiisoft/yii2 =2.0.3 -> satisfiable by yiisoft/yii2[2.0.3] but these conflict with your requirements or minimum-stability.
- cebe/assetfree-yii2 2.0.2 requires yiisoft/yii2 =2.0.2 -> satisfiable by yiisoft/yii2[2.0.2] but these conflict with your requirements or minimum-stability.
- cebe/assetfree-yii2 2.0.1 requires yiisoft/yii2 =2.0.1 -> satisfiable by yiisoft/yii2[2.0.1] but these conflict with your requirements or minimum-stability.
- cebe/assetfree-yii2 2.0.0 requires yiisoft/yii2 =2.0.0 -> satisfiable by yiisoft/yii2[2.0.0] but these conflict with your requirements or minimum-stability.
- yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
- yiisoft/yii2 2.0.5 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
- Conclusion: remove yiisoft/yii2 2.0.10
- Conclusion: don't install yiisoft/yii2 2.0.10
- cebe/assetfree-yii2 2.0.7 requires yiisoft/yii2 =2.0.7 -> satisfiable by yiisoft/yii2[2.0.7].
- cebe/assetfree-yii2 2.0.8 requires yiisoft/yii2 2.0.8 -> satisfiable by yiisoft/yii2[2.0.8].
- Can only install one of: yiisoft/yii2[2.0.7, 2.0.10].
- Can only install one of: yiisoft/yii2[2.0.8, 2.0.10].
- Installation request for yiisoft/yii2 (locked at 2.0.10, required as >=2.0.5) -> satisfiable by yiisoft/yii2[2.0.10].
- Installation request for cebe/assetfree-yii2 ^2.0 -> satisfiable by cebe/assetfree-yii2[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8].

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https:/ /getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https:/ /getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.


0

#2 User is offline   wgetus 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 10
  • Joined: 07-May 14

Posted 22 October 2016 - 03:00 PM

Что у тебя в composer.json в свойстве minimum-stability указано?

Вот подробнее об этом свойстве
https://getcomposer....nimum-stability
0

#3 User is offline   Kocmuk 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 22-October 16
  • Location:Russia, Saratov

Posted 22 October 2016 - 04:44 PM

View Postwgetus, on 22 October 2016 - 03:00 PM, said:

Что у тебя в composer.json в свойстве minimum-stability указано?


указано там следующее

"minimum-stability": "stable",

0

#4 User is offline   wgetus 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 10
  • Joined: 07-May 14

Posted 23 October 2016 - 01:20 AM

Попробуй изменить stable на dev. Должно помочь. Но имей ввиду что этим ты понижаешь требуемую стабильность устанавливаемых пакетов.
0

#5 User is offline   Kocmuk 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 22-October 16
  • Location:Russia, Saratov

Posted 28 October 2016 - 09:07 AM

View Postwgetus, on 23 October 2016 - 01:20 AM, said:

Попробуй изменить stable на dev. Должно помочь.


Спасибо, это помогло установить желаемое. Плюс обновил все, версии многих пакетов стали по больше ::)
0

#6 User is offline   wgetus 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 10
  • Joined: 07-May 14

Posted 02 November 2016 - 04:03 PM

Кстати, вот хорошая статья для ознакомления еще:
http://webtips.kraje...ty-application/
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users