Yii Framework Forum: probleme d'utilisation de yiic - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

probleme d'utilisation de yiic Rate Topic: -----

#1 User is offline   zaki chan 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 03-February 10

Posted 03 February 2010 - 02:53 PM

Bonjour,

Je débute tout juste avec le framework yii, j'ai installé Yii dans le répertoire www de wamp. Je dois maintenant utiliser yiic en tapant % YiiRoot/framework/yiic webapp WebRoot/testdrive sur la ligne de commande. Le problème est que lorsque je tape ceci le message suivant apparait:
'%' n'est pas reconnu en tant que commande interne ou externe, un programme éxécutable ou un fichier de commandes.

PS:J'utilise Windows vista
0

#2 User is offline   ouhman 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 118
  • Joined: 26-December 08

Posted 03 February 2010 - 03:01 PM

View Postzaki chan, on 03 February 2010 - 02:53 PM, said:

Bonjour,

Je débute tout juste avec le framework yii, j'ai installé Yii dans le répertoire www de wamp. Je dois maintenant utiliser yiic en tapant % YiiRoot/framework/yiic webapp WebRoot/testdrive sur la ligne de commande. Le problème est que lorsque je tape ceci le message suivant apparait:
'%' n'est pas reconnu en tant que commande interne ou externe, un programme éxécutable ou un fichier de commandes.

PS:J'utilise Windows vista


Le plus facile est d'ajouter le repertoire où se situe le framework dans la variable system PATH. Sur Windows XP: panneau config, system, avancé, variables d'environnement et dans variables système chercher Path.
Editer la variable en rajoutant ";c:\wamp\www\framework\yii\;" (chaque donnée est séparée par des points virgules).
Mets le repertoire absolu où se situe le framework Yii

Ensuite une fois dans ta ligne de commande tu peux faire:
C:\wamp\www>yiic webapp test

ce qui devrait marcher :)

Bon code
0

#3 User is offline   zaki chan 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 03-February 10

Posted 03 February 2010 - 03:36 PM

View Postouhman, on 03 February 2010 - 03:01 PM, said:

Le plus facile est d'ajouter le repertoire où se situe le framework dans la variable system PATH. Sur Windows XP: panneau config, system, avancé, variables d'environnement et dans variables système chercher Path.
Editer la variable en rajoutant ";c:\wamp\www\framework\yii\;" (chaque donnée est séparée par des points virgules).
Mets le repertoire absolu où se situe le framework Yii

Ensuite une fois dans ta ligne de commande tu peux faire:
C:\wamp\www>yiic webapp test

ce qui devrait marcher :)

Bon code


Ca ne marche pas, ca me met le message d'erreur suivant:

'yiic' n'est pas reconnu en tant que commande interne ou externe, un programme éxécutable ou un fichier de commandes.

Il ne faut pas remplacer quelque chose dans la commande car sur le site de yii y a écrit: Par convention, nous supposons que YiiRoot est le répertoire où Yii est installé, and WebRoot est la racine Web du serveur.
Lancer yiic sur la ligne de commande comme suit :

% YiiRoot/framework/yiic webapp WebRoot/testdrive
0

#4 User is offline   zaki chan 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 03-February 10

Posted 04 February 2010 - 05:40 AM

up
0

#5 User is offline   Raoul 

  • Master Member
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 634
  • Joined: 29-November 08
  • Location:Paris, France

Posted 04 February 2010 - 12:29 PM

Salut,
moi, dans framework/yiic.bat, j'ai remplacé

%PHP_COMMAND% "%YII_PATH%yiic" %*


par

%PHP_COMMAND% "%YII_PATH%yiic.php" %*


(remarque le .php)...et ça marche bien.
B)
1

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users