Yii Framework Forum: Installation of Composer and Yii JUI extension - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Installation of Composer and Yii JUI extension Rate Topic: -----

#1 User is offline   Simplicity 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 35
  • Joined: 26-November 14

Posted 26 November 2014 - 09:35 PM

Greetings Everyone,

I finished Installing Yii 2.0 framework basic on Linux Ubuntu 14.04 without having any problem. Now I want to use the DatePicker widget which i need to download Composer and install the JUI extension via the composer. Could anyone write simple steps to follow to avoid problems while downloading both. Thank you and have a great day.

0

#2 User is offline   Simplicity 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 35
  • Joined: 26-November 14

Posted 27 November 2014 - 01:10 AM

View PostSimplicity, on 26 November 2014 - 09:35 PM, said:

Greetings Everyone,

I finished Installing Yii 2.0 framework basic on Linux Ubuntu 14.04 without having any problem. Now I want to use the DatePicker widget which i need to download Composer and install the JUI extension via the composer. Could anyone write simple steps to follow to avoid problems while downloading both. Thank you and have a great day.



I Installed composer successfully then i proceed to install the extension "yii\jui" but first run this command for composer

$ composer global require "fxp/composer-asset-plugin:1.0.0-beta4"

This command to allow managing dependencies for (npm and bower) package through composer then i type to install the extension:

$ composer require --prefer-dist yiisoft/yii2-jui "*"

it finished successfully downloading the extension.

but after that i got two composer.json files one inside my project and the other at home directory

the one at home directoy includes only:
{
"require": {
"yiisoft/yii2-jui": "*"
}
}

and the other one in project includes everyting except "yiisoft/yii-jui": "*", after that i proceed to try DatePicker widget from this extension and it says "Class 'yii\jui\DatePicker' not found" with note that i used at the top of my page:

namespace yii\jui\DatePicker;
use yii\jui\DatePicker;

Hopefully anyone can enlighten me with the solution i will appreciate it, thanks.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users