Yii Framework Forum: Yii2 with yii2-admin and yii2-user pre-configured package - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Yii2 with yii2-admin and yii2-user pre-configured package Rate Topic: -----

#1 User is offline   Azraf 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 12
  • Joined: 14-April 12

Posted 22 November 2014 - 03:45 AM

I have created a package, that can be useful to some new Yii2 developers, who need user-profile with RBAC working example.
Hope this will be helpful at least few people.

Github Repository:
https://github.com/azraf/yii2-simple

GuideLine:
http://blog.makewebs...nd-few-more/234

N.B.
I have already working with AdminLTE for admin template, hope to add this admin them soon.
0

#2 User is offline   Tri69 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 22-November 14

Posted 22 November 2014 - 09:56 AM

Thanks so much for this package! I am looking for this.

I have download the Zip file at github.com/azraf/yii2-simple and extract it in my webroot localhost/yii2-simple-master/

After that I follow the installation guide step by step:
- composer install
- yii migrate/up --migrationPath=@vendor/azraf/yii2-simpleapp/migrations/initials
- composer update
- uncomment the line 'admin/*' of config/web.php
Everthing ok!

My webroot:
+ assets
+ commands
+ config
+ controllers
+ mail
+ messages
+ models
+ runtime
+ tests
+ vendor
+ views
+ web
.gitignore
LICENSE-yii.md
LICENSE.md
README.md
composer.json
composer.lock
requirements.php
yii
yii.bat
yii2simple.sql

But I browse to localhost/yii2-simple-master/index.php/admin/ -> The requested URL /localhost/yii2-simple-master/index.php/admin/ was not found on this server.

I don't see the admin folder in my webroot. I see the web folder and the index.php in it. Then I browse to localhost/yii2-simple-master/web/index.php -> Invalid Parameter – yii\base\InvalidParamException
The file or directory to be published does not exist: D:\wamp\www\yii2-simple-master\vendor\bower/jquery/dist

Please help me... Thanks
0

#3 User is offline   Nano 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 2
  • Joined: 08-January 13

Posted 22 November 2014 - 10:16 AM

From your webroot: you must browse to localhost/yii2-simple-master/web/index.php/admin
0

#4 User is offline   Tri69 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 22-November 14

Posted 22 November 2014 - 10:40 AM

View PostNano, on 22 November 2014 - 10:16 AM, said:

From your webroot: you must browse to localhost/yii2-simple-master/web/index.php/admin

Yes, I have tried it: localhost/yii2-simple-master/web/index.php/admin
But it error: Invalid Parameter – yii\base\InvalidParamException
The file or directory to be published does not exist: D:\wamp\www\yii2-simple-master\vendor\bower/jquery/dist
0

#5 User is offline   Tri69 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 22-November 14

Posted 22 November 2014 - 10:56 AM

Done! I have solved it. The problem is this package is missing bower folder in vendor... I have copied it from another Yii project and now it work!... ;D
0

#6 User is offline   Azraf 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 12
  • Joined: 14-April 12

Posted 22 November 2014 - 02:40 PM

View PostTri69, on 22 November 2014 - 10:56 AM, said:

Done! I have solved it. The problem is this package is missing bower folder in vendor... I have copied it from another Yii project and now it work!... ;D



Great! Thanks.
If you still facing issues, then please update the package from github [you can only update the composer.json in project root and config/web.php] and run
composer update
command.

Also, Please dont forget to check if your composer is well set. You may give a look at this post for that: http://blog.makewebs...ariable-fix/264

Thanks.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users