Yii Framework Forum: Installation On Windows Server - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Installation On Windows Server install, windows, server, guide Rate Topic: -----

#1 User is offline   BigJonMX 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 08-April 14

Posted 08 April 2014 - 09:55 AM

Does anyone anywhere know how to install Yii on a windows server?
Everything i've read here, and elsewhere, is just wrong!

The definitive guide states...
"2.Unpack the Yii release file to a Web-accessible directory."
"Tip: Yii does not need to be installed under a Web-accessible directory...should be protected from Web access..."
"After installing Yii, you may..."


And some people say Yii has good documentation - this is like a bad joke. (worse than MS documentation)

Our server has a folder per project. In IIS we create a website (and app pool) PER project.
It is simply not possible to have some vague web-accessible folder!?!?!

Can anyone explain?
[server 2008, iis7]
0

#2 User is offline   JFReyes 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 508
  • Joined: 28-October 09
  • Location:Puerto Rico

Posted 08 April 2014 - 10:15 AM

I have a few applications with a "WISPY" (Windows, IIS, SQL Server, PHP, Yii) configuration. Both Yii and the application reside in folders under c:\inetpub\wwwroot but Yii doesn't have to as long as you keep your pathnames straight. Only IIS_IUSR (and IUSR if you need it) need to have write access to a few select folders inside the app so you can use NTFS ACL's to protect the rest. As far as IIS is concerned the Yii app is a folder under wwwroot.

If you have specific questions perhaps I can be of further assistance.
José
0

#3 User is offline   BigJonMX 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 08-April 14

Posted 08 April 2014 - 11:21 AM

i just typed a lengthy reply, pressed submit, and got to see my reply as text. so i pressed back and ITS ALL GONE. AAAAAAHHHHHHHHhhhhhhhh. I've spent all day with this Yii and i've got nothing to show for it. My webapp would be almost finished by now!
I think i better leave it for now before i start cursing.
0

#4 User is offline   BigJonMX 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 08-April 14

Posted 08 April 2014 - 11:30 AM

i'm not posting any F-IN links !!!! And my text has disappeared AGAIN.

This kind of BUG annoys people to the point of mass murder. GGGGRRRRRRRrrrrrrrrr.
0

#5 User is offline   JFReyes 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 508
  • Joined: 28-October 09
  • Location:Puerto Rico

Posted 08 April 2014 - 12:17 PM

Sorry to hear about your troubles with the board. New users have limited posting capabilities to avoid spam. Perhaps you should try splitting your communication into smaller chunks that we can handle one at a time. I'll be here for a couple more hours... :)
José
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users