Yii Framework Forum: Yii User Management Module Setup - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Yii User Management Module Setup Rate Topic: -----

#1 User is offline   BarabashkaD 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 06-April 14

  Posted 06 April 2014 - 04:45 AM

I have fresh installation of web application just created with yiic webapp testsite
After that I flow instructions from github thyseus/yii-user-management
Now I try login to site.

If i login from testsite/site/login with admin/admin
and go to index.php/user/user/index
I get list of two users: admin and demo
however when I click on admin I get:
CException

Alias "ProfileModule.controllers.YumProfileController" is invalid. Make sure it points to an existing directory or file.

C:\inetpub\wwwroot\yii\framework\YiiBase.php(347)


If I login with widget application.modules.user.components.LoginWidget
And go to same testsite/index.php/user/user/index
and click on admin I get same exception


What is I miss in my setup process ?

Thanks
0

#2 User is offline   JbalTero 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 35
  • Joined: 18-January 14

Posted 06 April 2014 - 06:25 AM

Have you declared Alias in config/main.php?

Like, Yii::setPathOfAlias('Alias', dirname(__FILE__).'/../path/to/directory');
0

#3 User is offline   BarabashkaD 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 06-April 14

Posted 06 April 2014 - 06:48 AM

This line stay commented as after generation by yiic.
Is it should be uncomment ? What is a correct line should be?
0

#4 User is offline   BarabashkaD 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 06-April 14

Posted 06 April 2014 - 06:59 AM

Actually this is stack trace



#0
+ C:\inetpub\wwwroot\yii\framework\YiiBase.php(196): YiiBase::import("ProfileModule.controllers.YumProfileController", true)
#1
+ C:\inetpub\wwwroot\yii\framework\web\CWebApplication.php(332): YiiBase::createComponent(array("class" => "ProfileModule.controllers.YumProfileController"), "profile", ProfileModule)
#2
+ C:\inetpub\wwwroot\yii\framework\web\CWebApplication.php(338): CWebApplication->createController("profile/view/id/1/", ProfileModule)
#3
+ C:\inetpub\wwwroot\yii\framework\web\CWebApplication.php(276): CWebApplication->createController("profile/profile/view/id/1")
#4
+ C:\inetpub\wwwroot\yii\framework\web\CWebApplication.php(141): CWebApplication->runController("profile/profile/view/id/1")
#5
+ C:\inetpub\wwwroot\yii\framework\base\CApplication.php(180): CWebApplication->processRequest()

0

#5 User is offline   BarabashkaD 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 06-April 14

Posted 07 April 2014 - 07:18 AM

any ideas ?????
0

#6 User is offline   BarabashkaD 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 06-April 14

Posted 08 April 2014 - 02:45 AM

by the way, same shit with demo application .... may be some thing wrong because IIS7 & PHP 5.4 on my test server ?
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users