Yii Framework Forum: Srbac Assigning Roles Not Working Properly - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Srbac Assigning Roles Not Working Properly assigning roles-user/task-roles/operation-task

#1 User is offline   rundll 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 8
  • Joined: 28-April 13

Posted 11 January 2014 - 10:15 AM

I have successfully installed SRBAC to my Yii application but
I am having trouble assigning roles-user/task-roles/operation-task

Here is the process:

1.When I select a user on the User dropdown list
-The not assigned roles dropdown list will be populated which I think is normal

2.So normally I want to assign the Authority Role to my admin user

-So I will select the Authority role from the "not assigned role" dropdown.
-THEN HERE COMES THE PROBLEM:

When I click on the <<(left arrow button) to assign roles to the user it does load but nothing else happens.. It's not even assigning the role to that user.. I tried checking the AuthAssignment table, not a single record were there.
Then checked the response on console with firebug, everything seems OK, no errors were detected..

I've been stuck on this problem for almost 2 weeks now.. but still not giving up because I believe that this ext is very excellent. please help me Spyros thanks in advance..
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users