Yii Framework Forum: Faile For Using Composer - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Faile For Using Composer Rate Topic: -----

#1 User is offline   Manee 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 103
  • Joined: 23-September 12

Posted 12 December 2013 - 01:27 PM

Hi all.
after downloading new version of this framework. i can't using composer.

php composer.phar create-project --stability=dev yiisoft/yii2-app-basic basic

Warning: This development build of composer is over 30 days old. It is recommended to update it by running "composer.phar self-update" to get the latest version.


                                                                                               	
  [Composer\Downloader\TransportException]                                                     	
  The "https://packagist.org/packages.json" file could not be downloaded: Failed to enable crypto  
  failed to open stream: operation failed                                                      	
                                                                                               	


create-project [-s|--stability="..."] [--prefer-source] [--prefer-dist] [--repository-url="..."] [--dev] [--no-dev] [--no-plugins] [--no-custom-installers] [--no-scripts] [--no-progress] [--keep-vcs] [--no-install] [package] [directory] [version]     



php composer.phar self-update

                                                                                     	
  [Composer\Downloader\TransportException]                                                 	
  The "https://getcomposer.org/version" file could not be downloaded: Failed to enable crypto  
  failed to open stream: operation failed                                                  	
                                                                                           	
self-update

0

#2 User is offline   MartindeGroot 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 07-July 13

Posted 12 November 2014 - 09:27 AM

I am having the same problem with composer:

C:\wamp\www\yii2build>composer self-update



[Composer\Downloader\TransportException]
The "https://getcomposer.org/version" file could not be downloaded: php_net
work_getaddresses: getaddrinfo failed: Host is onbekend.
failed to open stream: php_network_getaddresses: getaddrinfo failed: Host i
s onbekend.

I have been googling about this, but sofar I could not find a solution.
I will appreciate any help you can give me.

Martin de Groot
0

#3 User is offline   Keith Scott 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 26-November 14

Posted 26 November 2014 - 07:59 AM

I hove not faced this problem in this framework, but I do not the solution. Perhaps you have override some default code.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users