Yii Framework Forum: مشکل با Url - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

مشکل با Url

#1 User is offline   Shahcheraghean 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 478
  • Joined: 12-December 12
  • Location:Mashhad, IRAN

  Posted 16 October 2013 - 12:04 PM


با سلام.
توی فایل config/main.php بخشی است که مربوط به urlManager است که اگر از حالت توضیحات درش بیاریم URL های ما به جای قالب زیر

site.com/index.php?r=post/create


به صورت

site.com/index.php/post/create


در میایند. امام بنده وقتی این کار را می کنم و آدرس را میزنم خطای


[b]Not Found[/b]
 The requested URL site.com/index.php/post/create was not found on this server.

Apache/2.2.22 (Ubuntu) Server at localhost Port 80

میگیرم. دلیل چیه؟ اشکال کارم کجاست؟

www.shgn.ir
www.shgn.ir/yii-framework/
yii2.swsco.ir
In a world without any fences or walls,Who needs Gates or Windows!
0

#2 User is offline   chalist 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 46
  • Joined: 16-December 12

Posted 16 October 2013 - 12:14 PM

مود rewrite رو فعال کردی؟
.htaccess چی؟
<?php 
/*
 * codeless documentation
 */
?>

@chalist
0

#3 User is offline   Ostovar IT 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 76
  • Joined: 09-June 11
  • Location:iran, tehran

Posted 17 October 2013 - 04:17 AM


شما در htaccess اصلی سایتت مقادیر زیر را وارد کن و ذخیره کن


IndexIgnore */*
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . index.php

ساختار آدرس سایت می شود :
site.com/controller/action
تحلیل، طراحی و برنامه نویسی وب، آموزش "ایی" فریمورک و برنامه نویسی وب، اخبار، مقالات، درج آگهی، استخدام و ... در وب سایت فناوری اطلاعات استوار
www.ostovarit.com
09128157188
0

#4 User is offline   Shahcheraghean 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 478
  • Joined: 12-December 12
  • Location:Mashhad, IRAN

Posted 25 October 2013 - 12:04 PM

با تشکر از دوستان.
این محتویات فایل تنظیمات بخش urlManager:


    	'urlManager' => array(
        	'urlFormat' => 'path',
        	'showScriptName' => false,
        	'caseSensitive' => false,
        	'rules' => array(
            	'<controller:\w+>/<id:\d+>' => '<controller>/view',
            	'<controller:\w+>/<action:\w+>/<id:\d+>' => '<controller>/<action>',
            	'<controller:\w+>/<action:\w+>' => '<controller>/<action>',
        	),
    	),

و این هم محتویات فایل htaccess. :

IndexIgnore */*
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . index.php

ولی همچنان هر آدرسی را که می زنم با خطا روبرو می شوم.Posted ImagePosted Image

www.shgn.ir
www.shgn.ir/yii-framework/
yii2.swsco.ir
In a world without any fences or walls,Who needs Gates or Windows!
0

#5 User is offline   Shahcheraghean 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 478
  • Joined: 12-December 12
  • Location:Mashhad, IRAN

Posted 30 October 2013 - 04:58 AM

up...

:(
www.shgn.ir
www.shgn.ir/yii-framework/
yii2.swsco.ir
In a world without any fences or walls,Who needs Gates or Windows!
0

#6 User is offline   rezaonline.net 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 108
  • Joined: 20-June 12

Posted 01 November 2013 - 07:37 AM

       'showScriptName' => true,

htaccess هم پاک کن نمیخواد
rezaworkshop.ir - rezaonline.net/blog
php5 , mysql , html5 , css3 , jquery + ajax
0

#7 User is offline   Shahcheraghean 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 478
  • Joined: 12-December 12
  • Location:Mashhad, IRAN

Posted 01 November 2013 - 09:47 AM

View Postrezaonline.net, on 01 November 2013 - 07:37 AM, said:

   	'showScriptName' => true,

htaccess هم پاک کن نمیخواد

مهندس دقیقا همونطور که گفتید مقدار 'showScriptName' را true کردم و فایل htaccess را هم همه محتویاتش را کامنت کردم. سایت به عنوان نمونه این آدرس را تولید کرده:

localhost/form-test/index.php/types/index

درسته؟
ولی باز هم همان خطا را می دهد.Posted Image

www.shgn.ir
www.shgn.ir/yii-framework/
yii2.swsco.ir
In a world without any fences or walls,Who needs Gates or Windows!
0

#8 User is offline   rezaonline.net 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 108
  • Joined: 20-June 12

Posted 06 November 2013 - 01:03 AM

ظاهرا آپاچی داره جفتک می اندازه بهتره از nginx استفاده کنید . :)

rezaworkshop.ir - rezaonline.net/blog
php5 , mysql , html5 , css3 , jquery + ajax
0

#9 User is offline   Shahcheraghean 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 478
  • Joined: 12-December 12
  • Location:Mashhad, IRAN

Posted 09 November 2013 - 12:08 AM

ممنون از جوابتون. به نظر همنیطور میاد.
حالا برای reset کردن تنظیمات apache در اوبونتو چند تا راه پیدا کردم، که به نظر بهرترینش پاک کردن آن با remove و نصب مجددش است. درسته؟
راه دیگه ای هم داره یا نه؟

www.shgn.ir
www.shgn.ir/yii-framework/
yii2.swsco.ir
In a world without any fences or walls,Who needs Gates or Windows!
0

#10 User is offline   rezaonline.net 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 108
  • Joined: 20-June 12

Posted 12 November 2013 - 02:57 AM

apt-get purge apache2
rezaworkshop.ir - rezaonline.net/blog
php5 , mysql , html5 , css3 , jquery + ajax
1

#11 User is offline   Hesam 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 66
  • Joined: 12-November 12
  • Location:Toronto

Posted 03 December 2013 - 05:31 PM

هنوز معلوم نیست که mod_rewrite
را فعال کردی یا نه
sudo a2enmod rewrite
sudo service apache2 restart

توی سایت هم باید این ها رو داشته باشی

<Directory /var/www/> Options Indexes FollowSymLinks MultiViews # changed from None to FileInfo AllowOverride FileInfo Order allow,deny allow from all </Directory>


View Postrezaonline.net, on 12 November 2013 - 02:57 AM, said:

apt-get purge apache2

0

#12 User is offline   Nabi 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 208
  • Joined: 22-February 12
  • Location:Ahwaz

Posted 08 December 2013 - 08:50 PM

توجه داشته باشید نحوه نمایش URL ها به دو شکل زیر:
1) site.com/index.php/post/create
2) site.com/post/create
دو بحث کاملاً مجزاست.

برای داشتن حالت اول که مد نظر شماست، تنها این تنظیمات مهمه:
'urlFormat'=>'path',
'showScriptName'=>true,

و هیچ ارتباطی هم به apache و mod_rewrite و htaccess. نداره!
پس تا اینجای کار، اگر به مشکلی برخورد میکنی، مشکل رو در جاهای دیگه جستجو کن.

چیزی که من حدس میزنم اونقدری سادست که شک دارم!
شما در متن خطایی که اینجا آوردید اینطور نوشتید:
The requested URL site.com/index.php/post/create was not found on this server.
آیا این خطا مستقیم توسط apache تولید شده و خطا رو کپی پست کردید؟! در این صورت وب سرور برای دسترسی از طریق دامنه مجازی site.com کانفیگ شده و با این دامنه سایتتون باز میشه؟
و مورد دیگه اینکه از وجود controller و action یی که استفاده میکنید مطمئن بشید.
بعد از اینکه این مشکل حل شد میتونیم درمورد حذف index.php از آدرس صحبت کنیم ;)


وقتی پیغام میذارید، بی زحمت متنتون رو انتخاب کنید و این دو تا کار ناقابل رو هم انجام بدید:
1. از اون بالا RTL رو انتخاب کنید.
2. فونت رو هم Tahoma بگذارید.
که چشمون در نیاد.
دمت گرم!

www.IranPHP.ir
1

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users