Yii Framework Forum: Yii + Oracle - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Yii + Oracle Ca marche bien (ou pas) ? Rate Topic: -----

#1 User is offline   RadicalDingos 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 41
  • Joined: 25-July 13

Posted 25 July 2013 - 11:17 AM

Bonjour à tous !

Premier topic pour moi, avec une question qui n'a pas l'air de revenir souvent (du moins de ce que j'ai pu en voir après une recherche poussée) : Yii et Oracle, est-ce que ça peut marcher ?

Alors je vous situe un peu mon problème actuel : je suis en charge du développement de la nouvelle mouture d'une application PHP (v5.3) et j'ai tout naturellement pensé à mon framework préféré pour remplacer le framework maison utilisé jusqu'à présent. Le problème (enfin j'espère que ça n'en sera pas un), c'est que l'application fonctionne avec une base de données Oracle 9i.

Actuellement, tout fonctionne bien, la gestion de la BDD se fait via le driver OCI de PHP via une classe faite maison. J'ai donc réalisé des tests pour vérifier que Yii (v1.1.13) fonctionnerait bien avec ce petit monde. 2 constats :
- Avec Gii, j'ai une lenteur incroyable lorsque j'essaie de générer les modèles. Même l'accès à la page de génération des modèles est lent (à cause des accès à la BDD).
- Une fois les modèles et le CRUD générés (à grands coups de patience), l'application est fonctionnelle, SAUF pour ajouter un nouvel enregistrement en base (l'update fonctionne nickel). Là il me plante une erreur CDbException et basta.

D'où ma première question : quelqu'un ici a t'il déjà réussi à faire fonctionner Yii et Oracle, et notamment Oracle 9 ? Avec vous rencontré ce genre de problème avec Gii ?

Merci d'avance !
0

#2 User is offline   grandoom 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 34
  • Joined: 11-July 12

Posted 30 July 2013 - 03:10 AM

peut être un début de réponse avec cet article

http://www.yiiframew...cle-through-pdo

apparemment il y aurait des petits soucis et il faut passer par une classe PDO...

bon courage..

Oracle Ô désespoir ô viellesse ennemie... :unsure:
0

#3 User is offline   RadicalDingos 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 41
  • Joined: 25-July 13

Posted 31 July 2013 - 11:01 AM

Merci pour ta réponse. Bon, je te le cache pas, j'ai déjà écumé le net, dont cet article, afin de résoudre mon problème. L'auteur fait d'ailleurs mention de dégradations de performances lors de l'utilisation d'Oracle avec Active Record. J'ai bien suivi à la lettre tout ce qu'il explique et ça n'a absolument rien changé. Le problème de cet article, c'est qu'il date visiblement de la v1.1.4 de Yii, et il ne mentionne pas la version d'Oracle avec laquelle il a réglé le problème...

Bref, je suis toujours à la recherche de retours d'expériences entre Yii et Oracle. D'ailleurs, je vais surement poser ma question sur le forum anglais, histoire de toucher un plus large éventail de dévs.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users