Yii Framework Forum: Composer Install Error On 1.1.14 - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Composer Install Error On 1.1.14 Rate Topic: -----

#1 User is offline   Raoul 

  • Master Member
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 636
  • Joined: 29-November 08
  • Location:Paris, France

Posted 23 July 2013 - 03:07 AM

Hi,
before posting an issue on Github, I'd like your opinion on this :
create a basic composer.json file :

{
	"name": "raoul/test1",
	"description": "this is a sample composer app",
	"authors": [
    	{
        	"name": "Raoul",
        	"email": "Raoul@mail.com"
    	}
	],
	"require": {
		"yiisoft/yii": "1.1.14-rc"
	}
}


..and then run "composer install". Here is the output :

Loading composer repositories with package information
Installing dependencies (including require-dev)
  - Installing yiisoft/yii (1.1.14-rc)
	Downloading: 100%

  [ErrorException]
  ZipArchive::extractTo(vendor/composer/43053e11/yiisoft-yii-3431553\framewor
  k\vendors\htmlpurifier\standalone\HTMLPurifier\ConfigSchema\schema/AutoForm
  at.RemoveEmpty.RemoveNbsp.Exceptions.txt): failed to open stream: No such f
  ile or directory


My expectation was that yii-1.1.14 was going to be downloaded into the vender folder ... but something wrong happened.
Any idea ?

ciao
B)
0

#2 User is offline   rahif 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 141
  • Joined: 11-July 13

Posted 24 July 2013 - 06:08 AM

Hello Raoul,

try change require to dev-master.

{
        "name": "raoul/test1",
        "description": "this is a sample composer app",
        "authors": [
        {
                "name": "Raoul",
                "email": "Raoul@mail.com"
        }
        ],
        "require": {
                "yiisoft/yii": "dev-master"
        }
}


In this link Explain
I hope it work, bye
0

#3 User is offline   Raoul 

  • Master Member
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 636
  • Joined: 29-November 08
  • Location:Paris, France

Posted 24 July 2013 - 07:13 AM

Hi Rahif,
thanks for your reply.
I did the modification and it works fine, however 2 points still confuse me.

1. If I want to use 1.1.14-rc, and no other version, now and in the future, isn't it an error to use "dev-master" ? I mean ok, today dev-master is the same as 1.1.14 because this version is the latest one to be released, but what about in some month, when 1.1.15 is released ?

2. in the Packagist repository, it is clearly written to use "1.1.14-rc"

ciao
8)
0

#4 User is offline   rahif 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 141
  • Joined: 11-July 13

Posted 24 July 2013 - 09:57 AM

you are right

1.1.14-rc should work but it doesnt.

I guess when 1.1.14 is finished the package 1.1.14 it'll be fine.

Sorry but my english is not very good.

bye
0

#5 User is offline   Raoul 

  • Master Member
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 636
  • Joined: 29-November 08
  • Location:Paris, France

Posted 24 July 2013 - 03:01 PM

no problem Rahif ... thanks for your help anyway ;)
ciao
B)
0

#6 User is offline   Raoul 

  • Master Member
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 636
  • Joined: 29-November 08
  • Location:Paris, France

Posted 02 August 2013 - 02:07 AM

anyone experienced the same problem ?
8)
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users