Yii Framework Forum: Performance Issue While Using Chtml Functions - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Performance Issue While Using Chtml Functions Rate Topic: -----

#1 User is offline   kumarkulandai 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 152
  • Joined: 18-November 11
  • Location:Bangalore

Posted 05 June 2013 - 02:26 AM

Hi,

I have faced the performance problem while using the CHTML functions like labekEx() to display the values

<?php echo $form->labelEx($mymodel,Yii::t($temptextg,'mycolumnid')); ?>
<?php echo $form->textField($mymodel,'mycolumnid'); ?>
<?php echo $form->error($mymodel,'mycolumnid'); ?>

Try to have 25 lables and 25 fields in the form and test it.

If i was using the normal label and text field, then the loading time is very fast.

Any idea how to improve the performance?
Regards,
Kumar Kulandai.

Posted Image
0

#2 User is offline   bettor 

  • Master Member
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 752
  • Joined: 02-February 09

Posted 05 June 2013 - 03:33 AM

What do you call a performance problem? Details? How did you measure it? Was there anything else rendered other than the form? I've rendered more than 25 in the past and it was lightning fast!
0

#3 User is offline   kumarkulandai 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 152
  • Joined: 18-November 11
  • Location:Bangalore

Posted 05 June 2013 - 10:35 PM

Hi,

Thanks for your reply,

I was unable to reproduce the problem, will reply you with example when the same issue reaccoured
Regards,
Kumar Kulandai.

Posted Image
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users