Yii Framework Forum: Requests For All Actions Leads To Main Page Instead - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Requests For All Actions Leads To Main Page Instead Rate Topic: -----

#1 User is offline   dmitridb 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 1
  • Joined: 09-May 13

Posted 09 May 2013 - 09:04 PM

Hello;

I've been faced up with an issue that I've been trying to get past with the deployment of a project imported onto my workstation. When attempting to do anything at all on the site, it only loads the main page. This all happens without any errors coming up in the logs at all, and for the access logs, it pulls through supposedly just fine with an HTTP status code of 200. I've iterated the question over at stackoverflow ( link omitted, as it won't let me post one with my newbie account - look up "yii-site-served-by-nginx-or-apache-only-serves-main-page" on google and it should come up ), and so far I haven't come up with much other than some advice on my nginx configuration. Attempting to do this on an apache setup rather than nginx has produced the same problems, so it's clear to me that this isn't a problem with the server configuration at this point. Considering I've got 2 other Yii projects set up which work fine, which are using similar server configs, I'm under the impression that the issue is something somewhere in the Yii project itself which needs to be addressed. If anyone has any suggestions for anything else I could share, try out, or compare to in the working projects I've imported and have working, it'd be greatly appreciated :)

EDIT ONE:

As per a suggestion in the #yii IRC channel, I replaced the contents of the .htaccess file with one from a working project. This hasn't yielded any change in the problem, however.

EDIT TWO:

I'll just copy over to pastebin for now the variety of kinds of requests that show up in the access logs, and how all return exactly what the root request returns, considering I can't paste anything with links in here still:
pastebin com/svumF7eE
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users