Yii Framework Forum: Terra Empresas - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Terra Empresas Rate Topic: -----

#1 User is offline   Mauro Julio Battassini 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 11
  • Joined: 28-August 12

Posted 21 March 2013 - 04:37 PM

Alguém ai já hospedou aplicação em YII no Terra Empresas?
A index abre tranquilo mas todas as internas dão 500 Internal Server Error.
Estou usando URL amigáveis ('urlFormat'=>'path').
Nem um phpinfo não consigo rodar no servidor.
Alguma ideia?
0

#2 User is offline   gbasto 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 70
  • Joined: 28-September 10
  • Location:Portugal

Posted 21 March 2013 - 06:44 PM

View PostMauro Julio Battassini, on 21 March 2013 - 04:37 PM, said:

Alguém ai já hospedou aplicação em YII no Terra Empresas?
A index abre tranquilo mas todas as internas dão 500 Internal Server Error.
Estou usando URL amigáveis ('urlFormat'=>'path').
Nem um phpinfo não consigo rodar no servidor.
Alguma ideia?


Tem algum .htaccess?
0

#3 User is offline   Mauro Julio Battassini 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 11
  • Joined: 28-August 12

Posted 21 March 2013 - 06:52 PM

AddDefaultCharset iso-8859-1
RewriteEngine On

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-f

RewriteRule . index.php
0

#4 User is offline   gbasto 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 70
  • Joined: 28-September 10
  • Location:Portugal

Posted 22 March 2013 - 06:35 AM

View PostMauro Julio Battassini, on 21 March 2013 - 06:52 PM, said:

AddDefaultCharset iso-8859-1
RewriteEngine On

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-f

RewriteRule . index.php


Apesar de não estar 100% correcta a configuração via .htaccess, não parece ser a fonte do problema.

Tem o YII_DEBUG a true e o php a mostrar erros?
0

#5 User is offline   Mauro Julio Battassini 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 11
  • Joined: 28-August 12

Posted 22 March 2013 - 07:27 AM

O servidor está configurado de forma a não mostrar os erros e não consigo mudar a diretiva.
Mesmo o debug true cai nessa tela de error.
0

#6 User is offline   gbasto 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 70
  • Joined: 28-September 10
  • Location:Portugal

Posted 22 March 2013 - 09:50 AM

View PostMauro Julio Battassini, on 22 March 2013 - 07:27 AM, said:

O servidor está configurado de forma a não mostrar os erros e não consigo mudar a diretiva.
Mesmo o debug true cai nessa tela de error.


Você tem um erro qualquer de programação, e sem a indicação do erro é complicado encontrá-lo.
0

#7 User is offline   Mauro Julio Battassini 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 11
  • Joined: 28-August 12

Posted 22 March 2013 - 11:48 AM

Pois é.
Está funcionando perfeitamente em três servidores diferentes.
Menos no Terra Empresas.
Vou tentar solicitar os logs do servidor.
Obrigado mesmo assim.
0

#8 User is offline   gbasto 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 70
  • Joined: 28-September 10
  • Location:Portugal

Posted 22 March 2013 - 12:59 PM

Só mais uma questão? Não tem outros .htaccess no projecto sem ser na raiz? Se sim qual o conteúdo e onde estão
0

#9 User is offline   Mauro Julio Battassini 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 11
  • Joined: 28-August 12

Posted 22 March 2013 - 04:21 PM

Não tem.
0

#10 User is offline   Newerton 

  • Master Member
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 811
  • Joined: 27-April 10
  • Location:Campo Grande/MS - Cambé/PR, Brasil

Posted 23 March 2013 - 11:36 AM

Sobe a pasta /requeriments/ dentro do zip do framework, e veja se 90% dos itens estão funcionando no servidor.

Se não me engano esses servidores particulares, são péssimo para suporte! O terra deve está usando um PHP antigo, desabilita erros, funções de email, habilita 100% as configurações de segurança, até o infeliz do suhosin!
Newerton Vargas de Araújo
0

#11 User is offline   Mauro Julio Battassini 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 11
  • Joined: 28-August 12

Posted 24 March 2013 - 07:26 PM

Consegui alterando o .htaccess
Se eu fosse esperar pelo suporte (sem comentários).
Segue o arquivo caso mais alguém tenha problemas:
AddDefaultCharset iso-8859-1
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)\?*$ index.php/$1 [L,QSA]

0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users