Yii Framework Forum: Traducción De Yii Al Español - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Traducción De Yii Al Español Rate Topic: -----

#1 User is offline   gunkan 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 7
  • Joined: 25-February 13

Posted 01 March 2013 - 03:19 AM

¿Sabéis como puedo añadir el español como lenguaje de Yii?

Donde pone "Incorrect username or password." que pusiera la traducción al español.

Investigando creo que hay que crear:

Quote

protected/messages/es


Y dentro un fichero php:

Quote

contentForm.php


¿Alguien ha realizado ya la traducción de los mensajes básicos?

Posdata: No entiendo porque hay que crear dos ficheros:
protected/messages/en/contentForm.php

y

Quote

protected/messages/id/contentForm.php

0

#2 User is offline   lagogz 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 478
  • Joined: 30-November 12
  • Location:Galiza

Posted 01 March 2013 - 03:34 AM

En config/main.php pones:

'language'=>'es',


Sin crear archivos ni gaitas.

Y listo.
-----------------------------------------------------------------------------------------------
------------------------------- VISITEN FOCUCHASART --------------------------------
-----------------------------------------------------------------------------------------------
1

#3 User is offline   gunkan 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 7
  • Joined: 25-February 13

Posted 01 March 2013 - 05:38 AM

¡Gracias voy a probarlo!

Edito: me ha cambiado el POWERED del pie de página por POTENCIADO, luego está funcionando. Pero los textos como "Incorrect username or password", me siguen apareciendo en inglés.
0

#4 User is offline   Juan Carrera 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 13
  • Joined: 05-October 12
  • Location:Zaragoza (Spain)

Posted 01 March 2013 - 12:53 PM

View Postgunkan, on 01 March 2013 - 05:38 AM, said:

¡Gracias voy a probarlo!

Edito: me ha cambiado el POWERED del pie de página por POTENCIADO, luego está funcionando. Pero los textos como "Incorrect username or password", me siguen apareciendo en inglés.



La aplicación que Yii crea al inicio no utiliza las funciones de internacionalización, las cadenas están fijas en el código. Para traducir la aplicación tienes que buscar cada cadena en el código y cambiarla. Si solo va a estar en español la cambias sin más. Si vas a tener más idiomas, cada cadena tiene que ir con Yii::t('cadenaClave'). Esta función es la que busca en los ficheros de messages. Si una clave no se encuentra (no está traducida) creo que aparece la clave como cadena.
0

#5 User is offline   m3mm0 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 7
  • Joined: 21-February 13

Posted 11 March 2013 - 05:54 PM

Mírate el videotutorial de Gustavo Salgado el Nro 16 buscalo en su canal en youtube

espero que lo puedas solucionar, ya que yo estoy con el mismo problema y ni aun con este video he podido solucionarlo.. algun error debo de tener por algun lado
0

#6 User is offline   robregonm 

  • Experienced Yii Developer
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 601
  • Joined: 30-July 09
  • Location:Colombia

Posted 11 March 2013 - 07:09 PM

En condiciones normales funciona (de hecho es una de las primeras cosas que activo al iniciar el desarrollo de una aplicación)
Pregunta:
Está usando alguna extensión para manejar los usuarios? Porque en esos casos cambia un poco el asunto.

Saludos.
Ricardo Obregón
LinkedIn Profile
YiiFramework en Español - http://yiiframework.co/ - Yii Code Generator for Bootstrap
http://obregon.co/ - https://1server.co/
PHP 5.5+, nginx, MySQL, PostgreSQL, Yii 1.x & 2.x, CanJS and more.
Follow me: @robregonm & @obregonco & @1ServerCo.
0

#7 User is offline   Gustavo Ramírez 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 22-April 13

Posted 22 April 2013 - 12:42 PM

View Postm3mm0, on 11 March 2013 - 05:54 PM, said:

Mírate el videotutorial de Gustavo Salgado el Nro 16 buscalo en su canal en youtube

espero que lo puedas solucionar, ya que yo estoy con el mismo problema y ni aun con este video he podido solucionarlo.. algun error debo de tener por algun lado


Hola m3mm0 has podido solucionar? yo también estoy haciendo los tutoriales de Gustavo Salgado y no me funciono para ciertas cosas por ejemplo las validaciones. Para cambiar los mensajes en las validaciones encontre este codigo: pastebin(punto)com/9v59XMKx, sin embargo no he podido cambiar la leyenda "Fields with * are required."
0

#8 User is offline   robregonm 

  • Experienced Yii Developer
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 601
  • Joined: 30-July 09
  • Location:Colombia

Posted 23 April 2013 - 11:41 AM

Cambiar los textos de las páginas de inicio de sesión, registro, etc, no es complicado, pero depende de si se está usando una extensión o no.
Por ejemplo, extensiones como yii-user y cruge, ya tienen incorporado el soporte de otros idiomas (hablando particularmente del español).
Si está usando el incorporado en yii (el creado por "yiic webapp") entonces notará que no funciona, porque necesita adicionar las vistas de idioma español (un directorio "es" dentro de las vistas) o en su defecto en la misma vista incluir "Yii::t(...)"
Ricardo Obregón
LinkedIn Profile
YiiFramework en Español - http://yiiframework.co/ - Yii Code Generator for Bootstrap
http://obregon.co/ - https://1server.co/
PHP 5.5+, nginx, MySQL, PostgreSQL, Yii 1.x & 2.x, CanJS and more.
Follow me: @robregonm & @obregonco & @1ServerCo.
0

#9 User is offline   robregonm 

  • Experienced Yii Developer
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 601
  • Joined: 30-July 09
  • Location:Colombia

Posted 23 April 2013 - 11:43 AM

Sea dicho de paso que los generadores de código no siempre generan el código con soporte para mútiples idiomas, en ese caso recomiendo una extensión llamada AweCrud (desarrollada por mí precisamente considerando ese punto y otros menores)
Ricardo Obregón
LinkedIn Profile
YiiFramework en Español - http://yiiframework.co/ - Yii Code Generator for Bootstrap
http://obregon.co/ - https://1server.co/
PHP 5.5+, nginx, MySQL, PostgreSQL, Yii 1.x & 2.x, CanJS and more.
Follow me: @robregonm & @obregonco & @1ServerCo.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users