Yii Framework Forum: Problema Búsqueda Dentro De Un Modulo - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Problema Búsqueda Dentro De Un Modulo no busca por el nuevo valor sino por el anterior Rate Topic: -----

#1 User is offline   Wmc 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 2
  • Joined: 20-August 11

Posted 22 February 2013 - 01:27 PM

Estas búsquedas las realizo en Advanced Search.

1. Busco en el campo category_id el valor "> 1" y doy click en buscar, después navego en las páginas de resultado.

2. Después de esto intento buscar
">2". Aquí ocurre el problema, carga la página con el valor de category_id en ">1"
Esta es la url que produce:
/laxinyii/panel/pCategory/admin/PCategory[category_id]/>1/PCategory[name]//PCategory_page/2?
PCategory[category_id]=>2&PCategory[name]=
Aquí se puede ver que como parte de la ruta del documento envía el valor anterior ">1" y después como parámetro el nuevo ">2"




0

#2 User is offline   Wmc 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 2
  • Joined: 20-August 11

Posted 22 February 2013 - 08:52 PM

Resuelto, el problema estaba en las reglas del UrlManager.

Agregue esto:
'<module:\w+>/<controller:\w+>/<action:\w+>'=>'<module>/<controller>/<action>'


Y todo bien.
Más referencias:
http://www.yiiframew...em-at-gridview/
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users