Yii Framework Forum: Can't Display More Than One Flash Chart With Xflexslider - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Can't Display More Than One Flash Chart With Xflexslider Rate Topic: -----

#1 User is offline   codepress 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 11
  • Joined: 27-August 12

Posted 06 February 2013 - 01:50 PM

Hi all,

I have a view in which I have a slider set up:
$this->widget('ext.xflexslider.XFlexSlider', array(
        "slides" => array(
            //use view
            'slide1' => array(
                'caption' => 'This image is wrapped in a link!',
                'view' => 'showchart1',
               
            ),
          'slide2' => array(
                'caption' => 'This image is wrapped in a link!',
                'view' => 'showchart2',
               
            ),
        ),
        
        'flexsliderOptions' => array(
            'animation' => "'slide'",
            //  'slideDirection' => 'vertical',
            'mousewheel' => true,
            'slideshow' => false,
            
        ),
    ));



The code in showchart one looks like this:

<?php

    $chart1 = Student::createlinechart(11);
    $this->widget(
            'application.extensions.OpenFlashChart2Widget.OpenFlashChart2Widget', array(

        'chart' => $chart1, // this is an object created using OpenFlashChart2's
        // PHP language binding.
        'width' => '100%',
        'height' => '400',
            )
    );

?>


and showchart2 :

<?php

      $chart2 = Student::createlinechart(23);
    $this->widget(
            'application.extensions.OpenFlashChart2Widget.OpenFlashChart2Widget', array(

        'chart' => $chart2, // this is an object created using OpenFlashChart2's
        // PHP language binding.
        'width' => '100%',
        'height' => '400',
            )
    );

?>


The problem is I can only display one of these charts if I remove the other slide. If I try to display both nothing shows up.

Any help appreciated, Thanks.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users