Yii Framework Forum: Bootstrap Less Mime Type Problem - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Bootstrap Less Mime Type Problem Rate Topic: -----

#1 User is offline   atlChris 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 2
  • Joined: 16-December 12

Posted 06 February 2013 - 12:15 AM

I added the yii-bootstrap extension to a webapp test project and was able to get it to work by creating a copy of less at: /assets/lib/bootstrap/less/. I thought I was doing ok because the few examples I tested worked fine when placed in the "about" page view. When I was trying to add "holder", I enabled all the console logging and there were many css warnings. The error message at the end in Firebug was:
The stylesheet ../assets/lib/bootstrap/less/mixins.less was not loaded because its MIME type, "text/plain", is not "text/css".
Hoping someone can help me find where this is being called from so I can set the type or provide a clue where I went wrong in the setup.

I'm not a programmer, just an old guy that enjoys running his own home web server and trying to learn yii (MVC).
Thanks,
Chris (yii ol' newb)
0

#2 User is offline   atlChris 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 2
  • Joined: 16-December 12

Posted 09 February 2013 - 06:12 PM

I think I found my answer...
http://www.yiiframew...le+#entry157283

but it wasn't using the newer alias yii format and it was a complex fix.
So, I gave up trying to fix all the problems with less.
Just too many moving parts for someone like myself (non-guru)looking for a simple framework with extensions for packages like bootstrap and less...
Perhaps yii is not the framework I'm looking for?
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users