Yii Framework Forum: Moved Directories And Now Permission Denied - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Moved Directories And Now Permission Denied Rate Topic: -----

#1 User is offline   rpaulpen 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 136
  • Joined: 01-December 08

Posted 24 January 2013 - 11:12 PM

Hi everyone,

I moved my directories around get "protected" out of the webroot. I followed these instructions on this wiki: http://www.yiiframew...roject-support: but am getting the following error.


But am getting this error:
[error] [client 192.168.3.1] PHP Warning:  require_once(/var/www/html/northware/yii/framework/yii.php): failed to open stream: Permission denied in /var/www/html/northware/html/index.php on line 13
[Thu Jan 24 22:59:58 2013] [error] [client 192.168.3.1] PHP Fatal error:  require_once(): Failed opening required '/var/www/html/northware/yii/framework/yii.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/northware/html/index.php on line 13


I tried permissions and htaccess. I opened the permissions but still get the above errors. This is working fine on my mac (mountain lion), but when I move it to Linux (Centos), I get these errors. I also tried different settings in the httpd.conf, but still a problem. I'm not sure where to look next. Any help would be appreciated.

Paul
0

#2 User is offline   jacmoe 

  • Elite Member
  • Yii
  • Group: Moderators
  • Posts: 2,601
  • Joined: 10-October 10
  • Location:Denmark

Posted 25 January 2013 - 01:42 AM

/* moved from Bug discussions ... */
"Less noise - more signal"
0

#3 User is offline   rpaulpen 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 136
  • Joined: 01-December 08

Posted 25 January 2013 - 02:22 PM

I ended up reinstalling on server. Not sure what caused it, but now working.
0

#4 User is offline   jacmoe 

  • Elite Member
  • Yii
  • Group: Moderators
  • Posts: 2,601
  • Joined: 10-October 10
  • Location:Denmark

Posted 25 January 2013 - 04:26 PM

Could just be the web server caching things. :)
"Less noise - more signal"
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users