Yii Framework Forum: Yii Cmemcache Error - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Yii Cmemcache Error YII CmemCache Error Rate Topic: -----

#1 User is offline   Rohit.28f 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 23
  • Joined: 11-August 11
  • Location:Bangalore,INDIA

Posted 28 December 2012 - 02:37 AM

Attached File  2012-12-28_130806.png (10.35K)
Number of downloads: 9Hi Guys,
Thanks in Advance. I have a issue regarding Yii Cmemcache. I am getting error as

Memcache::get() [<a href='memcache.get'>memcache.get</a>]: Server localhost (tcp 80) failed with: Malformed VALUE header (0)

Environment : PHP 5.3.8 (VC9) , XAMPP 1.7.7 , Windows XP service pack-2
Steps are as follows
1- installed compatible php_memcache.dll (VC9) file in my E:\php\ext directory.
2- Enabled extension in php.ini with "extension=php_memcache.dll"
3- Configured cache settings in config/main.php code is as follows
  'cache' => array(
                 	'class'   => 'system.caching.CMemCache',
                 	'servers' => array(
                                    	array('host'=>'localhost', 'port'=>80, 'weight' => 100),
                                   	),
                     	),


4- The cache settings are under component section of php.ini

5- Restarted Apache server
6- I am getting error as mentioned above.


Is there configuration any setting is wrong or problem with installation . Please help me ASAP.
BTW my PHP setting for memcache are in attachment .

Thanks again.Attached File  2012-12-28_130806.png (10.35K)
Number of downloads: 9

0

#2 User is offline   Patrick H 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 25-December 12

Posted 28 December 2012 - 07:55 AM

Port 80 ist (mostly) used by HTTP. The Default port for Memcached is 11211.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users