Yii Framework Forum: Jquery, Modals, And Yii! Strange Behavior - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Jquery, Modals, And Yii! Strange Behavior Strange behavior with Modal code Rate Topic: -----

#1 User is offline   imouthesmp 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 7
  • Joined: 08-May 12

Posted 05 December 2012 - 04:19 PM

Scenario: An a 'index' page containing multiple TbTabs, CGridviews, TbModal, and a Navbar Menu. The modals are added to the page via renderpartial....

First let me state the problem and behavior:
-Seemingly random tabs(TbTabs) and menu(TbMenu) links become unclickable. Now, I have some buttons that load a Modal page and after clicking and opening up the modal, the previously unclickable link(s) can now be clicked and act as you would expect
-I have a dropdown in one of these modals and when i click on a specific area of the navbar menu, it drops down without the modal opening or clicking the modal button!
Possible Conclusion:
-The 'hidden' modal html is being selected over the 'normal' html. This conclusion is supported by using FF to 'inspect' the area(s) described above with aberrant behavior and the inspector showing the modal elements and not the 'normal' viewable elements.
-Occurs in both FF and Chrome, so I'm guessing its browser neutral.

Background:
-Not sure if the following info is important but, modals are added to page via standard Tb way, so in my partial view i have something similar to the following code...
$this->beginWidget('bootstrap.widgets.TbModal', array('id' => 'dropShift')); ?>
///Div header body and footer with form /////
$this->endWidget();


and this is loaded in the main view via an ajax button like so...
                <?php
                $this->widget('bootstrap.widgets.TbButton', array(
                    'label' => 'Request DROP',
                    'url' => '#',
                    'htmlOptions' => array(
                        'data-toggle' => 'modal',
                        'data-target' => '#dropShift',),

                ));


Solutions:
No clue! This is really irritating and I don't even know where to begin to try to solve it. It's a serious detriment to the functionality of my web app and would appreciate any assistance that can be provided!

ImouthesMP
0

#2 User is offline   leibra 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 28-March 12

Posted 06 April 2013 - 01:55 AM

View Postimouthesmp, on 05 December 2012 - 04:19 PM, said:

Scenario: An a 'index' page containing multiple TbTabs, CGridviews, TbModal, and a Navbar Menu. The modals are added to the page via renderpartial....

First let me state the problem and behavior:
-Seemingly random tabs(TbTabs) and menu(TbMenu) links become unclickable. Now, I have some buttons that load a Modal page and after clicking and opening up the modal, the previously unclickable link(s) can now be clicked and act as you would expect
-I have a dropdown in one of these modals and when i click on a specific area of the navbar menu, it drops down without the modal opening or clicking the modal button!
Possible Conclusion:
-The 'hidden' modal html is being selected over the 'normal' html. This conclusion is supported by using FF to 'inspect' the area(s) described above with aberrant behavior and the inspector showing the modal elements and not the 'normal' viewable elements.
-Occurs in both FF and Chrome, so I'm guessing its browser neutral.

Background:
-Not sure if the following info is important but, modals are added to page via standard Tb way, so in my partial view i have something similar to the following code...
$this->beginWidget('bootstrap.widgets.TbModal', array('id' => 'dropShift')); ?>
///Div header body and footer with form /////
$this->endWidget();


and this is loaded in the main view via an ajax button like so...
                <?php
                $this->widget('bootstrap.widgets.TbButton', array(
                    'label' => 'Request DROP',
                    'url' => '#',
                    'htmlOptions' => array(
                        'data-toggle' => 'modal',
                        'data-target' => '#dropShift',),

                ));


Solutions:
No clue! This is really irritating and I don't even know where to begin to try to solve it. It's a serious detriment to the functionality of my web app and would appreciate any assistance that can be provided!

ImouthesMP


I am also having the same issue, anybody can help ?
0

#3 User is offline   jacmoe 

  • Elite Member
  • Yii
  • Group: Moderators
  • Posts: 2,601
  • Joined: 10-October 10
  • Location:Denmark

Posted 06 April 2013 - 08:20 AM

/* moved from Bug Discussions */
"Less noise - more signal"
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users