Yii Framework Forum: Permission To Phpmyadmin - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Permission To Phpmyadmin permission to phpmyadmin Rate Topic: -----

#1 User is offline   haikel 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 16-November 12

Posted 16 November 2012 - 06:27 PM

why it always write to me "You don't have permission to access /phpmyadmin/ on this server."
0

#2 User is offline   KonApaz 

  • Elite Member
  • PipPipPipPipPip
  • Yii
  • Group: Members
  • Posts: 1,276
  • Joined: 21-February 11
  • Location:Greece

Posted 16 November 2012 - 06:39 PM

Hi haikel,

Do you use localhost server like wamp/lamp?

Does php works in general way?

check the phpmyadmin.conf file for permissions
if use localhost also use 127.0.0.1 instead of localhost to check the problem
Yii is the best php framework in the world!
find our demo Yii extension on www.webkit.gr
Is it post useful? please v++ ;)
0

#3 User is offline   haikel 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 16-November 12

Posted 17 November 2012 - 12:51 PM

View PostKonApaz, on 16 November 2012 - 06:39 PM, said:

Hi haikel,

Do you use localhost server like wamp/lamp?

Does php works in general way?

check the phpmyadmin.conf file for permissions
if use localhost also use 127.0.0.1 instead of localhost to check the problem


Hi KonApaz,

yes i'm using wamp
it works when i tap 127.0.0.1, but i can not go into phpmyadmin when i tap localhost
0

#4 User is offline   KonApaz 

  • Elite Member
  • PipPipPipPipPip
  • Yii
  • Group: Members
  • Posts: 1,276
  • Joined: 21-February 11
  • Location:Greece

Posted 17 November 2012 - 01:12 PM

View Posthaikel, on 17 November 2012 - 12:51 PM, said:

Hi KonApaz,

yes i'm using wamp
it works when i tap 127.0.0.1, but i can not go into phpmyadmin when i tap localhost


check the httpd.conf file you have to set "Allow from all"

<Directory "c:/wamp/www/">
Options Indexes FollowSymLinks
AllowOverride all
Order Deny,Allow
Allow from all
</Directory>

Also check any issues with your antivirus (temporarly disable it)

also check your hosts file (C:/Windows/system32/drivers/etc) contains the following line
127.0.0.1 localhost

Best regards
Yii is the best php framework in the world!
find our demo Yii extension on www.webkit.gr
Is it post useful? please v++ ;)
0

#5 User is offline   haikel 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 16-November 12

Posted 18 November 2012 - 09:36 AM

View PostKonApaz, on 17 November 2012 - 01:12 PM, said:

check the httpd.conf file you have to set "Allow from all"

<Directory "c:/wamp/www/">
Options Indexes FollowSymLinks
AllowOverride all
Order Deny,Allow
Allow from all
</Directory>

Also check any issues with your antivirus (temporarly disable it)

also check your hosts file (C:/Windows/system32/drivers/etc) contains the following line
127.0.0.1 localhost

Best regards


this my first time i work on this framework

the howts file contains 127.0.0.1 localhost and htppd.conf contain "Allow from all"
i'm afraid that i didn't do it the intall of yiiframework very well :(
0

#6 User is offline   KonApaz 

  • Elite Member
  • PipPipPipPipPip
  • Yii
  • Group: Members
  • Posts: 1,276
  • Joined: 21-February 11
  • Location:Greece

Posted 18 November 2012 - 06:07 PM

View Posthaikel, on 18 November 2012 - 09:36 AM, said:

this my first time i work on this framework

the howts file contains 127.0.0.1 localhost and htppd.conf contain "Allow from all"
i'm afraid that i didn't do it the intall of yiiframework very well :(


in htppd.conf you will find
Allow from 127.0.0.1
change to
Allow from 127.0.0.1 ::1

restart wampserver

Also check
http://stackoverflow...myadmin-on-this

Les me know whether your problem fixed
Yii is the best php framework in the world!
find our demo Yii extension on www.webkit.gr
Is it post useful? please v++ ;)
0

#7 User is online   Maurizio Domba Cerin 

  • Yii - Yesss It Is !!!
  • Yii
  • Group: Yii Dev Team
  • Posts: 4,317
  • Joined: 12-October 09
  • Location:Croatia

Posted 19 November 2012 - 09:26 AM

NOTE: moved to proper section (General PHP Topics instead of General Discussion for Yii 1.1.x)
Find more about me.... btw. Do you know your WAN IP?
0

#8 User is offline   haikel 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 16-November 12

Posted 25 November 2012 - 08:59 AM

View PostKonApaz, on 18 November 2012 - 06:07 PM, said:

in htppd.conf you will find
Allow from 127.0.0.1
change to
Allow from 127.0.0.1 ::1

restart wampserver

Also check
http://stackoverflow...myadmin-on-this

Les me know whether your problem fixed


THANK YOU VERY MUCH KonApaz THE LINK THAT YOU SEND IT TO ME IS VERY HELPFUL, THANKS AGAIN :)
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users