Yii Framework Forum: Strange Cjuidialog Display Problem With Firefox - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Strange Cjuidialog Display Problem With Firefox Rate Topic: -----

#1 User is offline   Renaud 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 49
  • Joined: 04-October 11

Posted 16 November 2012 - 05:55 AM

Hi there,

I've got a strange bug with CJuiDialog and it only happens with Firefox (not with IE or Chrome).

When clicking the button that triggers the CJuiDialog, the CJuiDialog inner HTML content is first displayed very briefly where the "hook" <div> is on the main page. It lasts like a tenth of a second and then the CJuiDialog is displayed as expected.

It only happens the first time you click the button. It's quite strange, has anybody seen this before and managed to fix it ?

Cheers
Renaud
0

#2 User is offline   Keith 

  • Elite Member
  • Yii
  • Group: Moderators
  • Posts: 1,511
  • Joined: 04-March 10
  • Location:UK

Posted 16 November 2012 - 06:03 AM

Can you show the code? I imagine that wrapping the "hook" div in another div with style="display:none;" would probably fix the problem.
0

#3 User is offline   Renaud 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 49
  • Joined: 04-October 11

Posted 16 November 2012 - 08:55 AM

Thanks Keith it did the trick !
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users