Yii Framework Forum: Parametros Funcion - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Parametros Funcion Rate Topic: -----

#1 User is offline   desh 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 25
  • Joined: 10-October 12
  • Location:Guatemala

Posted 15 October 2012 - 12:45 PM

hola amigos, tengo duda sobre una funcion que realize, les explico esperando su ayuda.

yo hice un select puro y despues hice mi funcion en mi modelo, y le paso 4 variables que me envian de otra vista, pero esas 4 variables las recibo bien y las imprimo en pantalla. el problema es cuando las quiero mandar a mi funcion de mi modelo que no se como hacerlo, alguien me pude ayudar? gracias

en mi vista tengo esto, y si me muestra los datos que me envian

if(isset($_GET['TABLAS'],$_GET['USUARIO'],$_GET['OPERACION'])){
echo $_GET['TABLAS'].'-'.$_GET['USUARIO'].'-'.$_GET['OPERACION'];
} else{
echo "no";
}

//consultas('$tablas','$usuario','$accion','$fecha');


$this->widget('zii.widgets.grid.CGridView', array(
'id'=>'M_-grid',
'dataProvider'=>$model->consultas(),

'filter'=>$model,
'columns'=>array(

'USUARIO',
'USUARIO_AUDIT',
'OPERACION',
'FECHA_HORA',
)
));

y en mi modelo tengo asi mi funcion

public function consulas($pa1, $pa2,$pa3,$pa4){
//codigo php
}

la cosa esta que no me funciona, pero cuando quemo los datos en el cgrid si funciona, asi le paso parametos //'dataProvider'=>$model->consultas('AUDIT_T_CIUDADANOS1','pam','ins','11/10/12'),

alguien me podria ayudar para que pase parametros con variables normales y no quemadas
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users