Yii Framework Forum: problem with Apache and Yiic - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

problem with Apache and Yiic Apache is not recognized Rate Topic: -----

#1 User is offline   Jose Striedinger 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 18
  • Joined: 20-August 12
  • Location:Bogota, Colombia

Posted 21 August 2012 - 04:32 PM

Hi guys!

I have a fully MySQL+Apache+PHP5 environment in my laptop and I know it works but, for some reason everytine I call the yiic in the cmd it says "Apache is not recognized as a internal or external command" error. It makes no sense to me!

I have Apache 2.2 so I know that this version actually uses httpd.exe and not apache.exe and I already add the apache/bin path to my PATH environment variable.

I have no idea what to do next...

I would really appreciate the help, I want to get my hands on Yii!

Thanks.
0

#2 User is offline   yiqing95 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 586
  • Joined: 27-December 10
  • Location:china

Posted 21 August 2012 - 06:20 PM

it does no matter with apache.exe but the php.exe.
you should add the php.exe (the parent fold path ) to PATH


and try(cd to the proper dir) >php yiic ......

do you read the guide ? quick start
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users