Yii Framework Forum: holperiger Start ... - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

holperiger Start ... Rate Topic: -----

#1 User is offline   RHS 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 6
  • Joined: 18-December 08

Posted 18 December 2008 - 06:14 AM

Hallo allerseits,

dann will ich mal etwas mithelfen, die deutsche Rubrik zu füllen ... obwohl ich absoluter Anfänger bin  :).

Als Anfänger geht natürlich am Anfang alles schief. Ich kann bspw. die Skeleton-App nicht erstellen:

Parse error: syntax error, unexpected T_STRING,
expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}'
in /usr/www/users/rhs/yii/framework/YiiBase.php on line 49


Ich bin einfach nach Anleitung vorgegangen ...

In der Anleitung steht u.a. auch, das yii nicht im Web-Root liegen müsste. Wie rufe ich in dem Fall denn die Checkseite für yii auf ... ? Ok, Frage ist nicht ganz ernst gemeint ...  ;D


0

#2 User is offline   lupo 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 07-December 08

Posted 18 December 2008 - 03:52 PM

Verrat uns doch mal, was in deiner Applikation so um die Zeile 49 herum ist (dort scheint ja ein Problem zu sein)...

0

#3 User is offline   RHS 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 6
  • Joined: 18-December 08

Posted 18 December 2008 - 04:01 PM

Hallo lupo,

nun, ich hab ja noch keine Applikation ... und wollte die Start-Applikation erstellen. Der "Fehler" ist halt in der YiiBase.php. Die ist original. Die Zeile 49 lautet dort:


private static $_imports=array(); // alias => class name or directory;


Da kann nicht viel falsch sein.

Aufgerufen habe ich:

./yiic webapp ../testdrive

im Verzeichnis framework.


0

#4 User is offline   lupo 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 07-December 08

Posted 18 December 2008 - 04:15 PM

Sorry, ich war doch etwas zu schnell mit lesen. Ich vermute, dass das Problem eine Zeile weiter oben liegt, weil in Zeile 49 wirklich nicht viel falsch sein kann (wenn du PHP5 hast).
Ich vermute, dass das Problem in der Zeile obendran erzeugt wird und rate jetzt mal:
- du hast irgendwo einen Pfad gesetzt, evtl. für Alias
- du hast den Pfad mit doppelten Anführungszeichen und Backslash "xxxx\yyyy" definiert
Kann das sein?
Dann müsstest du entweder den Pfad mit doppelten Backslash schreiben "xxxxx\\yyyyy"  oder einfache Anführungszeichen verwenden 'xxxxx\yyyyy'.

Hoffe, dass das evtl. hilft...

0

#5 User is offline   RHS 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 6
  • Joined: 18-December 08

Posted 18 December 2008 - 04:22 PM

Hallo lupo,

nein, ich habe schlicht nichts verändert. Ich habe Yii runtergeladen, entpackt (Ordner Yii im Webroot), die Checkseite aufgerufen (alles grün) und wollte dann die Testapp generieren. Tja, da hänge ich nun ...

0

#6 User is offline   lupo 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 07-December 08

Posted 18 December 2008 - 04:41 PM

Meinst du mit Testapp diejenige gemäss Kap. 1.3 "Creating First Yii Application" im Guide oder was anderes?
Falls es diese ist, führ doch mal die genauen Kommandi auf, die du verwendest (also Eingaben in der Kommandozeile und im yiic-Tool).

(heute kann ich wahrscheinlich nicht mehr antworten)
0

#7 User is offline   RHS 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 6
  • Joined: 18-December 08

Posted 19 December 2008 - 02:43 AM

Hallo lupo,

Quote

Meinst du mit Testapp diejenige gemäss Kap. 1.3 "Creating First Yii Application" im Guide [...]


genau die.

Das Kommando für die Generierung lt. Doku bzw. Readme (steht ja schon oben).

0

#8 User is offline   RHS 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 6
  • Joined: 18-December 08

Posted 19 December 2008 - 03:08 PM

@all

Oh mann, peinlicher Fehler ...

Mein Server hat normal PHP 5.2.8, ruf ich aber in der Shell PHP auf, dann ist es nur die Version 4.4.9. Mit php5 ... lässt sich auch die Test-App erstellen.

*** Problem erledigt ****
0

#9 User is offline   lupo 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 5
  • Joined: 07-December 08

Posted 20 December 2008 - 09:22 AM

Tröste dich, da bin ich auch schon darüber gestolpert... Dann ist ja alles gut :)
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users