Yii Framework Forum: Erro 302 ao fazer login - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Erro 302 ao fazer login Rate Topic: -----

#1 User is offline   eestevao 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 14
  • Joined: 05-July 12

Posted 01 August 2012 - 10:16 AM

Olá a todos,

Bom estava começando bem no yii, tudo funcionando no apache no windows... dai migramos pro servidor de desenvolvimento que é linux e nginx...

Após acertar os redirecionamentos, estamos tendo problema com o login, sempre que vamos logar dá 302 (moved) e volta para a tela de login...

Quando ativamos register_globals (por acidente) funcionou perfeitamente..mas sei que por motivos de segurança é ideal que se mantenha desativado...

Por fim não encontramos nada nem nos logs da application nem do nginx..

Alguem tem alguma ideia do que possa ser?
0

#2 User is offline   Lothor 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 147
  • Joined: 05-August 11
  • Location:Brazil

Posted 01 August 2012 - 10:39 PM

Como estão os seus arquivos .htaccess?

Não fizesses algum redirecionamento direto em algum dos arquivos .haccess?
0

#3 User is offline   jjmf 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 63
  • Joined: 10-November 08

Posted 07 February 2013 - 08:23 PM

eestevao, conseguiu resolver esse problema do login? Estou passando pelo mesmo problema!
0

#4 User is offline   Newerton 

  • Master Member
  • PipPipPipPip
  • Yii
  • Group: Members
  • Posts: 824
  • Joined: 27-April 10
  • Location:Campo Grande/MS - Cambé/PR, Brasil

Posted 11 February 2013 - 08:55 PM

Verifica se não é algum direcionamento depois que a usuário é logado.

Ta usando alguma extensão para autorização e autenticação?
Newerton Vargas de Araújo
0

#5 User is offline   yigor 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 8
  • Joined: 14-February 13
  • Location:Brazil

Posted 14 February 2013 - 02:24 PM

Vc testou alguma pagina que não requisite o rewrite?

pode ser um mero problema de redirecionamento, verifica se teu .htaccess tem algo semelhante a isto.

location / {
  rewrite ^.*$ /index.php last;
}


ou se o rewrite ta configurado corretamente no teu nginx.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users