Yii Framework Forum: Error 500 - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Error 500 Only variables should be passed by reference Rate Topic: -----

#1 User is offline   milosbg 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 18-July 12

Posted 18 July 2012 - 10:08 AM

hello all,

To start, I am brand new to yii and had to pick up on someone else's code. I currently have the app running correctly on the server it's been on but when i try to put it in xampp it freaks out and tells me "Only variables should be passed by reference" I checked the application error log and have determined that the code snippet its complaining about is:

public function actionIncome_expense( $start_date = null, $end_date = null )
    {
        $report = new ReportIncome_expense;
        $report->set_dates($start_date, $end_date);

        $this->render('income_expense', array(
            'report' => $report,
        ));
    }


Any help would be appreciated :)
0

#2 User is offline   milosbg 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 18-July 12

Posted 18 July 2012 - 12:58 PM

To add more info to this I am using chrome as my browser and yii version 1.1.5 , php 5.3.8 and xampp 1.7.7
0

#3 User is offline   milosbg 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 18-July 12

Posted 18 July 2012 - 01:44 PM

Well it looks like I goofed on my end and didn't set my php.ini to disable E_Strict all is well now.
0

#4 User is offline   smoothcoder 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 29
  • Joined: 03-December 09
  • Location:Thailand

Posted 15 January 2013 - 12:47 AM

View Postmilosbg, on 18 July 2012 - 12:58 PM, said:

To add more info to this I am using chrome as my browser and yii version 1.1.5 , php 5.3.8 and xampp 1.7.7

Thanks again for this post. I had same "Error 500 internal server errors" and it spared me some searches!
So I just commented this line from my cgi/php.ini
;error_reporting = E_ALL & ~E_DEPRECATED
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users