Yii Framework Forum: Website Navigation Bar Bug - Yii Framework Forum

Jump to content

  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

Website Navigation Bar Bug Rate Topic: -----

#21 User is offline   bluyell 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 222
  • Joined: 28-October 11

Posted 23 April 2012 - 02:39 PM

View Postmdomba, on 22 April 2012 - 02:24 AM, said:

I'm still waiting for SebK to confirm that he did zoom to get this error... The whole menu is made with background images and when chrome zoom is used all those background images are misplaced for 1px, that's why the white line appears... not sure how and if to fix this as this is obvious a chrome issue...



this is a solution: adding a 1px border to the menu will fullfill this empty space.

// original file is: http://www.yiiframew.../css/layout.css
// applies only to chrome
//

.layout-main-header .menu li
{
position
:relative;
display
: inline;
margin
: 0;
padding
: 0;
float: left;
border
-right: 1px solid #999;
text
-transform:lowercase;
line
-height: 19.5px;

border
: 1px solid #999; // THIS LINE SOLVE THE PROBLEM WHEN CHROME ZOOMS TO 50%
}
0

#22 User is offline   Maurizio Domba Cerin 

  • Yii - Yesss It Is !!!
  • Yii
  • Group: Yii Dev Team
  • Posts: 4,353
  • Joined: 12-October 09
  • Location:Croatia

Posted 23 April 2012 - 03:23 PM

@bluyell

your solution does not work for the yii site as by giving a gray border makes other problems... as samdark already posted few posts before this is already solved and will be visible on next site deploy... the solution is to use a transparent border ;)
Find more about me.... btw. Do you know your WAN IP?
0

Share this topic:


  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users