Yii Framework Forum: Chapter #8: Problems with RbacCommand - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Chapter #8: Problems with RbacCommand

#1 User is offline   Lyoko 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 1
  • Joined: 17-March 12

Posted 19 March 2012 - 12:12 PM

I always get errors when trying to generate RBAC features in the command window. I tried to search solutions in yii forum but nothing works for me :-[
exception 'CDbException' with message 'CDbCommand failed to execute the SQL statement: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'teccollab.auth
assignment' doesn't exist. The SQL statement executed was: DELETE FROM `AuthAssignment`' in C:\Users\Haizz\Dropbox\yii\framework\db\CDbCommand.php:354
Stack trace:
#0 C:\Users\Haizz\Dropbox\yii\framework\db\CDbCommand.php(1229): CDbCommand->execute(Array)
#1 C:\Users\Haizz\Dropbox\yii\framework\web\auth\CDbAuthManager.php(557): CDbCommand->delete('AuthAssignment')
#2 C:\Users\Haizz\Dropbox\yii\framework\web\auth\CDbAuthManager.php(547): CDbAuthManager->clearAuthAssignments()
#3 C:\Users\Haizz\Dropbox\yii\teccollab\protected\commands\shell\RbacCommand.php(37): CDbAuthManager->clearAll()
#4 C:\Users\Haizz\Dropbox\yii\framework\cli\commands\ShellCommand.php(130): RbacCommand->run(Array)
#5 C:\Users\Haizz\Dropbox\yii\framework\cli\commands\ShellCommand.php(101): ShellCommand->runShell()
#6 C:\Users\Haizz\Dropbox\yii\framework\console\CConsoleCommandRunner.php(65): ShellCommand->run(Array)
#7 C:\Users\Haizz\Dropbox\yii\framework\console\CConsoleApplication.php(91): CConsoleCommandRunner->run(Array)
#8 C:\Users\Haizz\Dropbox\yii\framework\base\CApplication.php(162): CConsoleApplication->processRequest()
#9 C:\Users\Haizz\Dropbox\yii\framework\yiic.php(33): CApplication->run()
#10 C:\Users\Haizz\Dropbox\yii\teccollab\protected\yiic.php(7): require_once('C:\Users\Haizz\...')
#11 {main}



Here is my config/main.php
'components'=>array(
		'user'=>array(
			// enable cookie-based authentication
			'allowAutoLogin'=>true,
		),
		
		// uncomment the following to use a MySQL database
		
		'db'=>array(
			'connectionString' => 'mysql:host=localhost;dbname=teccollab',
			'emulatePrepare' => true,
			'username' => 'root',
			'password' => 'root',
			'charset' => 'utf8',
		),
                'authManager'=>array( 
                                 'class'=>'CDbAuthManager', 
                                 'connectionID'=>'db', 
                 ),
		'log'=>array(
			'class'=>'CLogRouter',
			'routes'=>array(
				array(
					'class'=>'CFileLogRoute',
					'levels'=>'error, warning',
				),
				// uncomment the following to show log messages on web pages
				/*
				array(
					'class'=>'CWebLogRoute',
				),
				*/
			),
		),
	),


My command:
yiic shell ..\index.php

I'm using Xampp on Windows to run Yii.
Thank for your help.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users