Yii Framework Forum: Celestic - Yii Framework Forum

Jump to content

  • (3 Pages)
  • +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

Celestic Another Web Based Project Manager Rate Topic: ***** 1 Votes

#21 User is offline   Vit78 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 45
  • Joined: 27-June 11
  • Location:Brisbane

Posted 31 March 2012 - 08:24 AM

v 0.4.0 works great on my localhost. tried to install it on shared hosting ( they've got latest yii version in standard packages in cpanel), could go to /?r=install&step=2 but after that had (after clicking finish link),

Request Timeout
This request takes too long to process, it is timed out by the server. If it should not be timed out, please contact administrator of this web site to increase 'Connection Timeout'.


I set in .htaccess


TimeOut 600
php_value max_execution_time 600


what else I can do? could it be database timeout?
a bit disappointed, but anyway great app, still use it locally.
0

#22 User is offline   SapporoGuy 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 177
  • Joined: 25-December 10
  • Location:Sappor Beer Refinery

Posted 31 March 2012 - 08:37 AM

Time outs normally occur because something went wrong.
But could happen if you're loading a huge MySQL file to build the db, but in this case I doubt that is the case since it doesn't have any demo data.
0

#23 User is offline   Vit78 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 45
  • Joined: 27-June 11
  • Location:Brisbane

Posted 31 March 2012 - 11:19 PM

it seems the problem happens only with the install routine, if I copy my local version to the shared hosting, it works just fine. perhaps I will run debugger/profiler to detect the issue.
0

#24 User is offline   Jack Fiallos 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 256
  • Joined: 15-October 09
  • Location:Mexico

Posted 31 March 2012 - 11:34 PM

Vit78 can you give me more details ?? I'm testing on different machines but I can't get the error..
Celestic Dev Team
Yii Open Source Project Manager
0

#25 User is offline   Vit78 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 45
  • Joined: 27-June 11
  • Location:Brisbane

Posted 01 April 2012 - 07:08 PM

View PostJack Fiallos, on 31 March 2012 - 11:34 PM, said:

Vit78 can you give me more details ?? I'm testing on different machines but I can't get the error..


this is the error

Quote

Request Timeout
This request takes too long to process, it is timed out by the server. If it should not be timed out, please contact administrator of this web site to increase 'Connection Timeout'.

but it seems like server error because of timeout, so there is no error inside application, so that's why I'm going to run debugger on install to see where it stumbled.
0

#26 User is offline   SapporoGuy 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 177
  • Joined: 25-December 10
  • Location:Sappor Beer Refinery

Posted 02 April 2012 - 12:53 AM

I got v4 installed the same as v3.

Installer didn't work for me.
0

#27 User is offline   Jack Fiallos 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 256
  • Joined: 15-October 09
  • Location:Mexico

Posted 02 April 2012 - 11:32 AM

Hi guys..

could tell me which version of mysql are you using?
Celestic Dev Team
Yii Open Source Project Manager
0

#28 User is offline   SapporoGuy 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 177
  • Joined: 25-December 10
  • Location:Sappor Beer Refinery

Posted 02 April 2012 - 12:24 PM

Mysql 5.0.8
Php 5.3.8
0

#29 User is offline   Jack Fiallos 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 256
  • Joined: 15-October 09
  • Location:Mexico

Posted 02 April 2012 - 12:36 PM

is that for shared hosting or localhost ?? ..

I'm ask, cuz I think the error it's caused by sql query.. ohh, i'm not sure yet

I'm using
insert into table (field1, field2) values ​​(1.2),
(3.4),
(5.6);


when it should
insert into (field1, field2) values ​​(1.2);
insert into (field1, field2) values ​​(3.4);
insert into (field1, field2) values ​​(5.6);

Celestic Dev Team
Yii Open Source Project Manager
0

#30 User is offline   SapporoGuy 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 177
  • Joined: 25-December 10
  • Location:Sappor Beer Refinery

Posted 02 April 2012 - 01:09 PM

I used localhost/~user/celistic/

My problem is related to the production file like i posted above. If manually override your code with the db.php file information the installer worked (??? But i also updated the with the files directly)
0

#31 User is offline   Jack Fiallos 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 256
  • Joined: 15-October 09
  • Location:Mexico

Posted 02 April 2012 - 01:27 PM

Hey SapporoGuy

to change between dev and production you have to edit celestic/index.php - YII_DEBUG true of false .. db.php its used by prod and dev environments..

It's almost the same configuration.. the main differents are logs messages
Celestic Dev Team
Yii Open Source Project Manager
0

#32 User is offline   SapporoGuy 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 177
  • Joined: 25-December 10
  • Location:Sappor Beer Refinery

Posted 02 April 2012 - 01:54 PM

I'll check that.
0

#33 User is offline   Vit78 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 45
  • Joined: 27-June 11
  • Location:Brisbane

Posted 02 April 2012 - 06:25 PM

The first sql statement syntax looks valid to me, in addition, I can run those quires via phpmyadmin. To check this assumption, I will clear mysql_data.sql content and try to run the install script, but again, it causes problems on shared hosting only, runs OK on localhost, maybe it's worth to check mysql versions...
0

#34 User is offline   Jack Fiallos 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 256
  • Joined: 15-October 09
  • Location:Mexico

Posted 03 April 2012 - 09:50 AM

I guess that's a problem with mysql versions ..

I'm making changes in queries using generic sql statements..
Celestic Dev Team
Yii Open Source Project Manager
0

#35 User is offline   Vit78 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 45
  • Joined: 27-June 11
  • Location:Brisbane

Posted 06 April 2012 - 09:08 PM

Server version: 5.5.16 - working copy
MySQL version 5.1.61-cll - shared hosting (not working)
I made some tests and found an error or issue somewhere in the file mysql_schema.sql (when I exclude this file, everything's OK)
I'll try to exclude some sql statements and locate the problem.
0

#36 User is offline   Vit78 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 45
  • Joined: 27-June 11
  • Location:Brisbane

Posted 06 April 2012 - 10:28 PM

phew, this was a tough one! nothing wrong with sql.
I located the problem in the
celestic\protected\modules\install\components\databaseConfiguration.php
commented out lines 36-39
// 				while (ob_get_level() > 0)
// 				{
// 				   ob_end_flush();
//  				}

looks like an indefinite loop.
According to http://au.php.net/ma...b-get-level.php ob_get_level has a quite funny behaviour.
The stars just are not in my favor on shared hosting :blink:
Hope it helps if someone has the same problem with installation.
0

#37 User is offline   Jack Fiallos 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 256
  • Joined: 15-October 09
  • Location:Mexico

Posted 08 April 2012 - 01:12 PM

Thnx for testing Vit78 ..!!

I guess the error occurs when ob_get_level is disabled on shared hosting ..

there something else.. I made the mistake of using methods ob_*() without using ob_start() .. if you have free time you can try making the following changes on databaseConfiguration file

//line 15 ..
ob_start();

//line 36 ..
while (@ob_get_level() > 0)

Celestic Dev Team
Yii Open Source Project Manager
0

#38 User is offline   Vit78 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 45
  • Joined: 27-June 11
  • Location:Brisbane

Posted 08 April 2012 - 06:50 PM

Hi Jack,

Your patch hasn't helped, I've got a time-out again(((

Oh, man, you make me to do weird things, I mean reading docs))

ob_get_level always returns 1 or greater value for PHP with setting zlib.output_compression to "On".
I have gzip compression on my shared hosting.
So, it would be nice if you modify your script to check compression somehow

if (zlib_get_coding_type())
	$limit = 1;
else
	$limit = 0;
while (ob_get_level() > $limit)
{
....

this works for both shared and local hosting (at least for me))

cheers
0

#39 User is offline   Jack Fiallos 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 256
  • Joined: 15-October 09
  • Location:Mexico

Posted 08 April 2012 - 10:19 PM

Damn it..!!

thank you man for your help.. I've tested in 4 different servers and never got the error..

now with your correction.. i'll update the code and upload in the next version..
Celestic Dev Team
Yii Open Source Project Manager
0

#40 User is offline   viorakis 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 1
  • Joined: 03-January 12

Posted 24 April 2012 - 04:34 PM

Hi Jack,

Very nice application, thanks for sharing it with us.
I really want to try to work with it involving my team.
Sadly, something is missing for me: a help file.
Not for installing but for using the application.
Do you have something that explain in depth the logic behind the app?
On first impression all is clear, but if you want to start a real environment, you have to know exactly the logic.

Looking forward for your answer,

Viorel
0

Share this topic:


  • (3 Pages)
  • +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

2 User(s) are reading this topic
0 members, 2 guests, 0 anonymous users