Yii Framework Forum: Problema em arquivo index.php (Iniciante) - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Problema em arquivo index.php (Iniciante) Rate Topic: -----

#1 User is offline   geandjay 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 1
  • Joined: 08-June 09

Posted 08 June 2009 - 10:55 AM

Srs, saudações.

Sou iniciante com o framework Yii e preciso de ajuda,
já fiz a instalação, chequei os Requirements, configurei o db no arquivo main.php
'db'=>array(
            'connectionString'=>'mysql:host=localhost;dbname=meu_banco',
            'username'=>'meuUserName',
            'password'=>'minhaSenha',), //apenas para teste

Em Requirements so falta o  CMemCache os demais estão todos "verde"

Apos acessar
yiic shell ../index.php pela prompt de comando
e digitar
>> crud  tabempresas

Obtenho o retorno com o seguinte texto:
Exception 'CDBException' with message " CDBException failed to open the DB connection: Could not find driver in c:\wamp\www\yii\framework\db\CDBConnection.php.
.
.
.
Ao checar esse arquivo verifico que ele existe sim...

minha aplicação fica no diretorio c:\wamp\www\geanApp

jã chequei tambem que o mysql está rodando...

Agradeço, qualquer ajuda...
geandjay@gmail.com

0

#2 User is offline   ricardograna 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 376
  • Joined: 31-March 09
  • Location:Manaus/AM - Brazil

Posted 08 June 2009 - 01:11 PM

O MySQL está rodando, mas vc tem que ativar os modulos php_pdo e pdo_mysql para funcionar.

Qq coisa grita aih :)
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users