Yii Framework Forum: On Scenario Doesn't work! - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

On Scenario Doesn't work! validators doesn't work when using on scenario

#1 User is offline   Alireza Nasseh 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 14
  • Joined: 29-July 11
  • Location:Iran

Posted 15 October 2011 - 09:29 AM

با سلام،
در قسمت rules مدل وقتی از on=>scenario استفاده می کنم، validator مشخص شده کار نمی کند و وقتی بخش on=>scenario را برمی دارم درست کار می کند. به نظرتون مشکل کار از کجاست؟

کدی که کار نمی کند :

array('pass', 'required', 'on'=>'index'),


و کدی که کار می کند :

array('pass', 'required'),

0

#2 User is offline   naser 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 85
  • Joined: 30-October 09
  • Location:tehran - Iran

Posted 16 October 2011 - 02:12 AM


وقتی که از یه رول می خوایید تو سناریو استفاده کنید باید موقع ساختن object مدلتون سناریو رو مشخص کنید



$model = new user('index');

1

#3 User is offline   Alireza Nasseh 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 14
  • Joined: 29-July 11
  • Location:Iran

Posted 16 October 2011 - 03:33 AM

View Postnaser, on 16 October 2011 - 02:12 AM, said:


وقتی که از یه رول می خوایید تو سناریو استفاده کنید باید موقع ساختن object مدلتون سناریو رو مشخص کنید



ممنون از راهنماییتون درست شد

0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users