Yii Framework Forum: [EXTENSION] phundament - Yii Framework Forum

Jump to content

  • (11 Pages)
  • +
  • « First
  • 2
  • 3
  • 4
  • 5
  • 6
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic

[EXTENSION] phundament Phundament 3: Yii CMS based upon independent modules and extensions Rate Topic: ***** 3 Votes

#61 User is offline   Chris-S 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 32
  • Joined: 08-January 12
  • Location:Ohio

Posted 02 April 2012 - 03:43 AM

Sounds good, just have to decide how we want to implement everything on our end.
ARC cms - www.goarc.org
Yii based cms with mybb forum software integrated!
0

#62 User is offline   schmunk 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 568
  • Joined: 02-November 08
  • Location:Stuttgart, Germany

Posted 02 April 2012 - 04:50 AM

Yes, that's one of the basic ideas of Phundament you CAN, but you DON'T HAVE TO.
Most developers already have their workflows and shouldn't be forced to change them. Nonetheless, if you want to present an out-of-the-box working solution, you have to choose some defaults.
Phundament - Yii Application Boilerplate with composer support
Fork on github

Follow phundament on Twitter

DevSystem: Mac OS X 10.7 - PHP 5.3 - Apache2 - Yii 1.1 / trunk - Firefox or Safari
0

#63 User is offline   SapporoGuy 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 177
  • Joined: 25-December 10
  • Location:Sappor Beer Refinery

Posted 02 April 2012 - 04:49 PM

View Postschmunk, on 30 March 2012 - 04:24 AM, said:

Looks like you've not updated config/main.php with the Phundament config.



I have phundament as the main directory and yii as as subdirectory.

Where do I find this Phundament config?
0

#64 User is offline   schmunk 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 568
  • Joined: 02-November 08
  • Location:Stuttgart, Germany

Posted 03 April 2012 - 02:58 AM

If you used the composer version it's in p3/main.php if you're using the download it's in protected/config/main.php and the current github clone is protected/config/p3main.php. :o Sorry for that, I'll consolidate this into protected/config/p3main.php

But I got a few problems with composer on windows, which currently limits the easy distribution of Phundament. look here for more details.

If someone on Windows could try the composer installation from https://github.com/phundament/app I would be thankful.
Some get errors, when trying to install it - for some others it works fine?!

I'll try to provide ZIP files for all packages, this seems currently a very stable way to fetch updates.
Phundament - Yii Application Boilerplate with composer support
Fork on github

Follow phundament on Twitter

DevSystem: Mac OS X 10.7 - PHP 5.3 - Apache2 - Yii 1.1 / trunk - Firefox or Safari
0

#65 User is offline   schmunk 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 568
  • Joined: 02-November 08
  • Location:Stuttgart, Germany

Posted 03 April 2012 - 05:57 AM

Just a note: I got a working composer installation with PHP 5.3.10, git and hg.
Phundament - Yii Application Boilerplate with composer support
Fork on github

Follow phundament on Twitter

DevSystem: Mac OS X 10.7 - PHP 5.3 - Apache2 - Yii 1.1 / trunk - Firefox or Safari
0

#66 User is offline   ametad 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 78
  • Joined: 08-February 12
  • Location:Holland

Posted 03 April 2012 - 07:52 AM

Hi Tobias,

I have noticed no problems with composer. And with install-p3.sh all repo's (yii, phundament-app, p3media, etc) were succesfully downloaded from Github. But I don't use the windows commandline, I use a commandline in Aptana Studio 3 what I think is a ported Linux commandline.

Are you already making progress with P3-App? Or is the windows installation still problematic? Sorry to say, but I cannot provide you with results using the windows commandline. It's not configured properly yet.

Can you tell me a bit more about p3pages perhaps? After a fresh install of phundament-app, the top-menu navigation has the following items: home, page*, contact, login, en (language selector). But "contact" points to http://localhost/phundament-app/{route:'/site/contact'}. Is this supose to be? How did you plan to use this?
It looks to me that there is need for some conversion after it's taken out of the database into the link...

Greetings!
0

#67 User is offline   schmunk 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 568
  • Joined: 02-November 08
  • Location:Stuttgart, Germany

Posted 03 April 2012 - 12:16 PM

Hi ametad,

View Postametad, on 03 April 2012 - 07:52 AM, said:

Hi Tobias,

I have noticed no problems with composer. And with install-p3.sh all repo's (yii, phundament-app, p3media, etc) were succesfully downloaded from Github. But I don't use the windows commandline, I use a commandline in Aptana Studio 3 what I think is a ported Linux commandline.

Nice, that sounds good, btw: I unified the file locations for the setup and the config.

View Postametad, on 03 April 2012 - 07:52 AM, said:

Are you already making progress with P3-App? Or is the windows installation still problematic? Sorry to say, but I cannot provide you with results using the windows commandline. It's not configured properly yet.

Sorry, but I am confused. setup-p3.sh just creates a Yii WebApplication skeleton runs the database migrations and sets a handful of directory permissions - it does not download anything?! :) Did you get Phundament 3 via Yii Extensions, git clone --recursive or composer?
The composer installation should now run fine on Windows, I tried it with PHP 5.3.10, but it should also work with 5.3.2, according to Jordi (2:32 PM).

View Postametad, on 03 April 2012 - 07:52 AM, said:

Are you already making progress with P3-App? Or is the windows
Can you tell me a bit more about p3pages perhaps? After a fresh install of phundament-app, the top-menu navigation has the following items: home, page*, contact, login, en (language selector). But "contact" points to http://localhost/phundament-app/{route:'/site/contact'}. Is this supose to be? How did you plan to use this?
It looks to me that there is need for some conversion after it's taken out of the database into the link...

Greetings!

P3Pages is a module to dynamically create pages, the error you see is because of an incorrect migration value for this page, but this should be fixed. Maybe you could also edit the page manually in the backend
In the admin backend you currently can specify a layout and view or a route (JSON string) for the page, along with translations for pageTitle and so on ... it's still pretty alpha yet. I'll come up with more details soon.

Could you try the composer installation again?


Thanks & best regards,
schmunk
Phundament - Yii Application Boilerplate with composer support
Fork on github

Follow phundament on Twitter

DevSystem: Mac OS X 10.7 - PHP 5.3 - Apache2 - Yii 1.1 / trunk - Firefox or Safari
0

#68 User is offline   schmunk 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 568
  • Joined: 02-November 08
  • Location:Stuttgart, Germany

Posted 03 April 2012 - 03:10 PM

Hi ametad,

OK I can reproduce the bug now, got it here fixed (see below): http://demo.phundame...nt-app-7f714cf/
But not on my Mac and Windows dev machine. Will drop a short note here, when it's fixed.
.........
fixed in https://github.com/s...749ef37d5f623b1

With a composer installation you could run php composer.phar update.
Then either fix it manually by updating the records or drop the p3page tables and run the setup (migrations) again.

Please let me know, if this now works for you.


Best regards,
schmunk
Phundament - Yii Application Boilerplate with composer support
Fork on github

Follow phundament on Twitter

DevSystem: Mac OS X 10.7 - PHP 5.3 - Apache2 - Yii 1.1 / trunk - Firefox or Safari
0

#69 User is offline   SapporoGuy 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 177
  • Joined: 25-December 10
  • Location:Sappor Beer Refinery

Posted 04 April 2012 - 03:58 AM

:huh: :huh: I'm just not understanding how to install this :( :(

I decided to try all over with a clean directory and the newest version on github!

My steps that I did::

Downloaded the latest revision from github: phundament3-0.3.1-71667dcd.tar.gz

added everything in that tar file to a directory called: phundment3

Also added the yii/framework files to that same directory:phundament3

Just in case ran: chmod 777 recursive on the phundament3 directory (localhost: easier to not worry about permissions ;) )

cd into phundament3 and ran: protected/setup-p3.sh "/Users/SapporoGuy/Sites/phundament3/yii/framework/yiic"
-- no errors and everything looks good!

go to site: http://127.0.0.1/~Sa...ment3/index.php
-- get Yii looking page :unsure:

edit protected/config/main.php :: name'=>'phundament3',
-- get Yii looking page but with a new title


Is there a step not mentioned in the readme or on the site that I am missing? :unsure:
0

#70 User is offline   ametad 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 78
  • Joined: 08-February 12
  • Location:Holland

Posted 04 April 2012 - 04:14 AM

View Postschmunk, on 03 April 2012 - 12:16 PM, said:

...
Sorry, but I am confused. setup-p3.sh just creates a Yii WebApplication skeleton runs the database migrations and sets a handful of directory permissions - it does not download anything?! :) Did you get Phundament 3 via Yii Extensions, git clone --recursive or composer?
The composer installation should now run fine on Windows, I tried it with PHP 5.3.10, but it should also work with 5.3.2, according to Jordi (2:32 PM).
...


OOPS, I did confuse you because I ment to say that MY LOCAL COMPUTER configuration is not setup correctly yet! (e.g. windows path, etc.)

I have installed Phundament-App again and I really like it man :)) :)) !! Nice job! Especially the extended LESS support. For theming this will be handy and this was what I was looking for :) Also the build in functionality of adding pages.

Kind regards,
A

PS. The normal Phundament installation gives errors:
Submodule path 'protected/extensions/phundament/p3extensions': checked out '023ea6efed0edf47bd16259e4636298681eb7d4f'
Cloning into protected/extensions/phundament/p3install...
fatal: https://github.com/schmunk42/p3install.git/info/refs not found: did you run git update-server-info on the server?
Clone of 'https://github.com/schmunk42/p3install.git' into submodule path 'protected/extensions/phundament/p3install' failed

0

#71 User is offline   SapporoGuy 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 177
  • Joined: 25-December 10
  • Location:Sappor Beer Refinery

Posted 04 April 2012 - 04:31 AM

Hey Ametad!

How did you install this?
0

#72 User is offline   luc 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 211
  • Joined: 22-June 10
  • Location:france

Posted 04 April 2012 - 04:32 AM

Hi, I'm trying to install your nice phundament app but terminal complains:
  [Composer\Downloader\TransportException]                                                
  The "https://api.github.com/repos/schmunk42/p3extensions" file could not be downloaded  

when I run: php composer.phar update --install-suggests
Hey Ho !
Let's go !
0

#73 User is offline   schmunk 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 568
  • Joined: 02-November 08
  • Location:Stuttgart, Germany

Posted 04 April 2012 - 05:13 AM

@SapporoGuy:
Have a look at the Troubleshooting section under https://github.com/phundament/app

Please try:
php -d allow_url_fopen=1 -d memory_limit=64M composer.phar -v update

Phundament - Yii Application Boilerplate with composer support
Fork on github

Follow phundament on Twitter

DevSystem: Mac OS X 10.7 - PHP 5.3 - Apache2 - Yii 1.1 / trunk - Firefox or Safari
0

#74 User is offline   luc 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 211
  • Joined: 22-June 10
  • Location:france

Posted 04 April 2012 - 06:10 AM

 [Composer\Downloader\TransportException]                                                
  The "https://api.github.com/repos/schmunk42/p3extensions" file could not be downloaded  
                                                                                          


Exception trace:
 () at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Util/RemoteFilesystem.php:148
 Composer\Util\RemoteFilesystem->get() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Util/RemoteFilesystem.php:72
 Composer\Util\RemoteFilesystem->getContents() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Repository/Vcs/VcsDriver.php:86
 Composer\Repository\Vcs\VcsDriver->getContents() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Repository/Vcs/GitHubDriver.php:230
 Composer\Repository\Vcs\GitHubDriver->fetchRootIdentifier() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Repository/Vcs/GitHubDriver.php:63
 Composer\Repository\Vcs\GitHubDriver->initialize() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Repository/VcsRepository.php:64
 Composer\Repository\VcsRepository->getDriver() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Repository/VcsRepository.php:84
 Composer\Repository\VcsRepository->initialize() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Repository/ArrayRepository.php:134
 Composer\Repository\ArrayRepository->getPackages() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/DependencyResolver/Pool.php:38
 Composer\DependencyResolver\Pool->addRepository() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Installer.php:154
 Composer\Installer->run() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Command/UpdateCommand.php:63
 Composer\Command\UpdateCommand->execute() at phar:///var/www/yii/appli/phundament-app/composer.phar/vendor/symfony/console/Symfony/Component/Console/Command/Command.php:237
 Symfony\Component\Console\Command\Command->run() at phar:///var/www/yii/appli/phundament-app/composer.phar/vendor/symfony/console/Symfony/Component/Console/Application.php:193
 Symfony\Component\Console\Application->doRun() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Console/Application.php:70
 Composer\Console\Application->doRun() at phar:///var/www/yii/appli/phundament-app/composer.phar/vendor/symfony/console/Symfony/Component/Console/Application.php:106
 Symfony\Component\Console\Application->run() at phar:///var/www/yii/appli/phundament-app/composer.phar/src/Composer/Console/Application.php:59
 Composer\Console\Application->run() at phar:///var/www/yii/appli/phundament-app/composer.phar/bin/composer:9
 require() at /var/www/yii/appli/phundament-app/composer.phar:15



git and hg commands are available on my system (ubuntu linux 10.04).
Hey Ho !
Let's go !
0

#75 User is offline   schmunk 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 568
  • Joined: 02-November 08
  • Location:Stuttgart, Germany

Posted 04 April 2012 - 06:21 AM

Which PHP Version so you have? 5.3.2 is required.
Could you also try the verbose switch ... php composer.phar -v
Phundament - Yii Application Boilerplate with composer support
Fork on github

Follow phundament on Twitter

DevSystem: Mac OS X 10.7 - PHP 5.3 - Apache2 - Yii 1.1 / trunk - Firefox or Safari
0

#76 User is offline   luc 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 211
  • Joined: 22-June 10
  • Location:france

Posted 04 April 2012 - 06:28 AM

Hi, thank you for help.
I'm running php 5.3.2, above was the result given in verbose mode ...
Hey Ho !
Let's go !
0

#77 User is offline   schmunk 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 568
  • Joined: 02-November 08
  • Location:Stuttgart, Germany

Posted 04 April 2012 - 06:46 AM

Have you also tried this?
php -d allow_url_fopen=1 -d memory_limit=64M composer.phar -v update

Many PHP installations have allow_url_fopen disabled by default.

Thanks & best regards,
schmunk
Phundament - Yii Application Boilerplate with composer support
Fork on github

Follow phundament on Twitter

DevSystem: Mac OS X 10.7 - PHP 5.3 - Apache2 - Yii 1.1 / trunk - Firefox or Safari
0

#78 User is offline   luc 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 211
  • Joined: 22-June 10
  • Location:france

Posted 04 April 2012 - 10:24 AM

Sorry for replying a bit late. Yes I've tried your suggestion with same result.

[edit]: I'm behind a proxy, and it looks like passing thru it with command line request is impossible. I will try again later at home and keep you in touch.
Hey Ho !
Let's go !
0

#79 User is offline   schmunk 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 568
  • Joined: 02-November 08
  • Location:Stuttgart, Germany

Posted 04 April 2012 - 11:18 AM

View Postluc, on 04 April 2012 - 10:24 AM, said:

Sorry for replying a bit late. Yes I've tried your suggestion with same result.

[edit]: I'm behind a proxy, and it looks like passing thru it with command line request is impossible. I will try again later at home and keep you in touch.


Thanks for your reply, this may be a problem.
I am not that deep into composer, but you may post your problem here. Can you download other stuff via PHP?

In the meantime, I'll try to setup the download package again (also for @SapporoGuy), and
git clone --recursive https://github.com/schmunk42/phundament.git
cd phundament
./protected/setup-p3.sh /path/to/yii/framework
edit index.php


$config=dirname(__FILE__).'/protected/config/p3.php';


should work again.


Best regards,
schmunk
Phundament - Yii Application Boilerplate with composer support
Fork on github

Follow phundament on Twitter

DevSystem: Mac OS X 10.7 - PHP 5.3 - Apache2 - Yii 1.1 / trunk - Firefox or Safari
0

#80 User is offline   schmunk 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 568
  • Joined: 02-November 08
  • Location:Stuttgart, Germany

Posted 04 April 2012 - 01:05 PM

Hi guys,

please check the latest Phundament 3-0.4-RC1 download archive.

Should include a bunch-o-fixes and has extended LESS support prepared.

A Quick How-To:
* config/main.php: Enable lessCompiler in preload section and set lessCompiler.autoCompile = true (only for development)
* give the webserver write permissions for protected/extensions/phundament/themes/p3bootstrap/css/p3.css
* modify ../phundament/themes/p3bootstrap/less/variables.less according to your needs

The p3.css file should be recreated every request with your modified values. You may also add LESS stuff to p3.less, which imports bootstrap via a blueprint-bootstrap translation file, so you're able to use existing Yii views. It also imports the variables after that, so it overrides the bootstrap defaults.

[edit]
Note: You'll reach the default max nesting level of PHP with an enabled lessCompiler and you'll need xdebug to override this.


Would love to hear, if this works for you.


Best regards,
schmunk

This post has been edited by schmunk: 04 April 2012 - 01:13 PM

Phundament - Yii Application Boilerplate with composer support
Fork on github

Follow phundament on Twitter

DevSystem: Mac OS X 10.7 - PHP 5.3 - Apache2 - Yii 1.1 / trunk - Firefox or Safari
0

Share this topic:


  • (11 Pages)
  • +
  • « First
  • 2
  • 3
  • 4
  • 5
  • 6
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic

2 User(s) are reading this topic
0 members, 2 guests, 0 anonymous users